Bord de coupe

Asked by Gérald Champavert on 2010-09-24

Bonjour.

Dans une version à venir, auriez vous moyen de prévoir la notion de bord de coupe utilisée par les imprimeurs ? Il est généralement de 1mm sur chaque côté, agrandissant ainsi mécaniquement le document de 2mm dans le sens de la hauteur et de 2mm dans le sens de la largeur.

Merci par avance.

Question information

Language:
French Edit question
Status:
Answered
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2010-09-24
Last reply:
2010-09-24
jazzynico (jazzynico) said : #1

Bonjour,

Il existe une extension, déjà présente en version 0.47, qui devrait vous aider. Elle se trouve dans le menu Extensions>Rendu>Marques d'impression, et permet de définir les coupes, marques de fond perdu, étoiles, etc.
Une fois appliquée, vous pouvez ensuite redimensionner votre document pour intégrer ces marques avec la boîte de dialogue Fichier>Propriétés du document (puis ajuster la page au dessin).

Bonne journée !

Merci.

J'ai testé dans l'instant car je suis en pleine création d'affiches associatives, mais j'ai eu un "méchant" message erreur et il n'arrive pas à créer le fond perdu.
Voici le message si cela peut aider :
La fantastique classe lxml pour libxml2 est nécessaire à inkex.py et par conséquent à cette extension. Veuillez en télécharger et installer la dernière version à partir du site http://cheeseshop.python.org/pypi/lxml/, ou l\u2019installer directement avec votre gestionnaire de paquet avec une commande du type : sudo apt-get install python-lxml

Sorry ! La réponse est dans le message ! Je vois qu'il faut que j'installe les libxml2. La fatigue de bon matin ! Donc, je laisse quand même la question ouverte jusqu'à lundi au plus tard, n'ayant pas le temps de faire le nécessaire. Je reviens ensuite, pour, j'espère, fermer le ticket.

Bonne journée !

jazzynico (jazzynico) said : #4

Avec quel système d'exploitation travaillez-vous ?
Le paquet d'installation pour Windows intègre déjà cette bibliothèque, mais ce n'est pas forcément le cas pour OSX ou un GNU/Linux.

Je suis avec Mac OS X Snow Leopard 10.6.4 et j'ai l'ensemble du kit de développement. Je sais avoir déjà compilé, linké, installé les libxml2 pour un autre produit (PHP 5) il y a un an et demi quand j'ai customisé mon Mac, et donc il faut certainement que je procède à la bonne déclaration de ce que j'ai déjà (PATH et compagnie). Je travaille avec Mac OS X comme avec Linux avec lequel je travaille depuis de longues années. J'ai donc l'habitude de me tordre les neurones sur ce genre de problème. Mais là, je dois arrêter mes créations d'affiches car le travail m'appelle tout simplement, et c'est pour cela que je disais faire ceci d'ici lundi au plus tard.

Je vous tiens au courant et vous remercie de la grande aide que vous m'avez déjà apportée.

su_v (suv-lp) said : #6

Bug #482993 “Inkscape extensions do not work on MacOS X 10.6 (Snow Leopard)”:
<https://bugs.launchpad.net/inkscape/+bug/482993>

If you want to use externally compiled and installed python modules lxml and numpy (for the system python version or in MacPorts), you will need to remove the ones that come bundled inside Inkscape.app i.e. rename the 'python' folder in 'Inkscape.app/Contents/Resources' or - if that fails, edit $PYTHONPATH in the shell script 'Contents/Resources/bin/inkscape'.

Can you help with this problem?

Provide an answer of your own, or ask Gérald Champavert for more information if necessary.

To post a message you must log in.