0.48 Crash on first boot on mac OSX 10.6.4

Asked by nico on 2010-08-30

Hi,

I've search for same problem in vain, and you maybe can help me finding the right problem source.
I'm on Mac OSX 10.6.4 with the last xQuartz (2.5.3) on a macbook pro 13'', and when I launch Inkscape 0.48 (the same for the latest snapshot from 30/08), I got this log in my terminal :

------------------------------

dway:~ nico$ /Applications/Inkscape.app/Contents/MacOS/Inkscape
Warning: AppleCollationOrder setting not found, using AppleLocale.
Setting Language: fr_FR.UTF-8
Xlib: extension "RANDR" missing on display "/tmp/launch-OZcpke/org.macosforge.xquartz:0".
/Users/nico/.inkscape-etc/gtkrc:56: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
/Users/nico/.inkscape-etc/gtkrc:57: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
/Users/nico/.inkscape-etc/gtkrc:58: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.

(inkscape-bin:818): Gtk-WARNING **: Could not find the icon 'object-visible'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
 http://icon-theme.freedesktop.org/releases

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.

------------------------------

Then I see the inkscape window, and a dialog box saying than an internal error happened so Inkscape will close.

I can see only warning in the console log, Is there a log file with more information I could find ?
Note that the 0.47 works perfectly (I've reinstall it after to continue working).

Thx in advance !

Question information

Language:
English Edit question
Status:
Answered
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
su_v (suv-lp) said : #1

Note that when launching Inkscape like you did from the terminal there can be unintended side effects (depending on the environment you set up for bash in your user account): it is recommended to launch Inkscape by double-clicking the application icon in the Finder or the dock. You can view the console messages with 'Applications > Utilities > Console' (choose 'All messages' from the log list). In Console you also have access to the most recent crash reports Mac OS X automatically creates when an application crashes (look at the most recent ones for the process 'inkscape-bin'). The crash reports are saved in 'Home > Library > Logs > DiagnosticReports'.

The crash report could be more helpful in determining the cause of the crash because the console messages you pasted here are normal (except the "Emergency save activated! …" messages).

Possibly the same issue as reported in
Bug #623640 “inkscape 0.48 crashes on startup in colorprofile_get_system_profile_handle()”:
<https://bugs.launchpad.net/inkscape/+bug/623640>
(crash when parsing installed color profiles)

nico (nicolasderambure) said : #2

~suv, thanks for helping, and here is the informations.
I've tried to launch with the icon double-clic too last time, sorry to have forgotten this. But same crash.

So I've looked in the console app, and can see exactly same output than my previous message, no more information...

It looks like I can't add an attachment to this thread so here is my crash report of inkscape-bin :
http://pastie.org/private/awdendp2nvkit73xs7vw

Hope this can help !

su_v (suv-lp) said : #3

Thank you for following up - looking at the crash report you pasted, it is the same issue as reported in bug #623640. The same type of crash had been reported earlier on Windows as well (bug #608229, with a development build of 0.48), indicating that it is not limited to a certain platform, e.g. Mac OS X only.

The exact cause is not known yet, possibly due to "corrupt" color profiles or - if not "corrupt" - color profiles that Inkscape fails to handle well if it can't parse/load them.

In bug #623640 I linked to a discussion in the German Inkscape user forum, where the problem had been reported to be solved by repairing the installed color profiles with the Apple's 'ColorSync' utility (using several passes and removing any remnants of profiles with seemingly corrupt information manually in the terminal). I cannot verify or redommend the procedure as a workaround because on my OS X Leopard installation Inkscape 0.48 doesn't expose this error (0.46, 0.47 and 0.48 launch without errors related to loading/parsing color profiles).

I will link your question to the bug report - you will receive email notifications about any progress or known workarounds to get 0.48 launching without crash. You can unsubscribe yourself from the bug report at any time, if you don't or no longer wish to track the issue: use the 'Unsubscribe' link at <https://bugs.launchpad.net/inkscape/+bug/623640>.

nico (nicolasderambure) said : #4

Thank you again for your clear explanations !
Ok for following bug, hope a solution will be found soon !

Can you help with this problem?

Provide an answer of your own, or ask nico for more information if necessary.

To post a message you must log in.