How to Change default close to quit behaviour ?

Asked by alexshr on 2010-07-16

When I am working only on a single document in Inkspace (no multiple instances of Inkspace), then closing of this single document quits the Inkspace. And to work on new document I have start a new instance of Inkspace. This could have been a lot easier if there is any option so that closing that document only closes that particular document which I am working on and leave the main Inkspace window as it is, so that I can start working there after in new document.

I don't know if this is bug in Inkspace.

So, I am also giving my system specs,
Output of "uname -r -v ":
2.6.35-6-generic #9-Ubuntu SMP Wed Jun 30 23:09:46 UTC 2010

OS: Maverick Meerkat (Development Release alpha)
Inkspace Version : Inkscape 0.47 r22583, built Apr 4 2010

one more question, how to start Inkspace in debug mode ?

-samundra

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
jazzynico
Solved:
2010-07-16
Last query:
2010-07-16
Last reply:
2010-07-16
Best jazzynico (jazzynico) said : #1

> This could have been a lot easier if there is any option so that closing that document only closes that particular document which I am working on and leave the main Inkspace window as it is

There's a request for enhancement about it (now linked to this question).

> one more question, how to start Inkspace in debug mode ?

There's a --g-fatal-warnings command line option (man says: "This standard GTK option forces any warnings, usually harmless, to cause Inkscape to abort (useful for debugging)."). But I suggest that you use gdb (command line) or Nemiver (GUI)

Regards.

alexshr (samundra-shrestha) said : #2

Thanks JazzyNico.

alexshr (samundra-shrestha) said : #3

Wish to see the changes of close-to-quit behaviour in upcoming releases of Inkspace.

I just learnt how to debug programs, thanks again JazzyNico. The information was really helpful. It helped me a lot.

-samundra

alexshr (samundra-shrestha) said : #4

Thanks JazzyNico, that solved my question.