After installing Inkscape 0.47-3 for Windows (XP) it crashes when opening

Asked by Bob on 2010-04-21

I'm running Windows XP SP3 and inkscape-0.46.win32 works fine, but after installing Inkscape-0.47-3.exe I receive the following message when opening Inkscape: "Inkscape encountered an internal error and will close now."

The error signature reads:
AppName: inkscape.exe AppVer: 0.47.0.0 ModName: msvcrt.dll
ModVer: 7.0.2600.5512 Offset: 00037740

Has anyone run into this before?

Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2010-04-27
Last reply:
2010-04-28
jazzynico (jazzynico) said : #1

Hi,

There are some reported Windows crashes in the bug report system, but the Windows specific libraries have been updated recently and some of these crashes should be fixed now.

Would you be willing to try the development version (http://inkscape.modevia.com/win32/?M=D) and confirm that your issue is also fixed? You just need to uncompress the most recent 7zip file and run it directly from the uncompressed folder.

Thanks!

Bob (correa68) said : #2

Hi,

Thanks for the response.

I downloaded the most recent version (inkscapeR9369-1004250415.7z 25-Apr-2010 01:17 30M) but unfortunately I'm still receiving the same error message.

I'm still open to suggestions, Thanks

jazzynico (jazzynico) said : #3

Hi,

One thing you can also try is renaming your preferences.xml file. We've already seen cases where some 0.46 parameters led to instabilities with 0.47. The file is in "C:\Documents and Settings\%USERNAME%\Application Data\Inkscape". Please save the older file, which could help us fix the issue (if related, of course).

You could also run Inkscape from the command line, with a small program called inkscapec, as explained at http://kaioa.com/node/63. It could help catching an error message, and thus give us an useful clue as to what causes the crash.

Thanks!

Bob (correa68) said : #4

Hi,

Renaming preferences.xml produced the same error message.

I went on to your other suggestion (not sure if I did this correctly)
Below are the results, to save space I did not include the whole error; it just repeated the last line.

Also, it refers to the hicolor theme pack, where does this belong on a Windows machine?

___________________

C:\Documents and Settings\ROCO\Desktop\inkscapeR9369-1004250415\inkscape>inkscap
ec.exe

(inkscape.exe:3552): Gtk-WARNING **: Could not find the icon 'object-visible'. T
he 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
        http://icon-theme.freedesktop.org/releases

(inkscape.exe:3552): GLib-CRITICAL **: g_convert: assertion `str != NULL' failed
___________________

jazzynico (jazzynico) said : #5

Hi,

These messages should be fixed with the dev version you have tried.

One more thing you could do is completely remove the C:\Program Files\Inkscape (uninstall inkscape with the uninstaller, and delete the remaining files manually). It looks like if there are still 0.46 things in it. And I remember we've already had that kind of installer issue.

Can you help with this problem?

Provide an answer of your own, or ask Bob for more information if necessary.

To post a message you must log in.