What are the exact dependencies?

Asked by Kalsan on 2015-02-27

I'm trying to compile indicator-multiload on Arch Linux, but the make fails. I tried to install the libraries described in HACKING: "You need at least vala 0.14 and devel packages for glib, gtk+ 3.0, cairo, appindicator and libgtop 2.0"
Unfortunately, make is still not able to complete. I suspect that these would be the dependencies to build the software under Ubuntu only.
Could you please povide exact dependencies to build indicator-multiload on any system?
Thanks in advance,
Kalsan

Question information

Language:
English Edit question
Status:
Solved
For:
System Load Indicator Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Hofmann
Solved:
2015-03-03
Last query:
2015-03-03
Last reply:
2015-03-03
Michael Hofmann (mh21) said : #1

Hi Kalsan,

the dependencies sound quite ok. Could you post the error messages of make?

Cheers
Michael

Kalsan (info-kalsan) said : #2

$ cd indicator-multiload/

$ ls
AUTHORS autogen.sh* configure.ac COPYING data/ HACKING Makefile.am po/ README src/ TODO
sandro@lp-sandro-arch ~/D/indicator-multiload> ./autogen.sh
checking for automake >= 1.11.2...
  testing automake... found 1.15
checking for autoreconf >= 2.53...
  testing autoreconf... found 2.69
checking for intltool >= 0.25...
  testing intltoolize... found 0.50.2
checking for pkg-config >= 0.14.0...
  testing pkg-config... found 0.28
Checking for required M4 macros...
**Warning**: I am going to run `configure' with no arguments.
If you wish to pass any to it, please specify them on the
`/usr/bin/gnome-autogen.sh' command line.

Processing ./configure.ac
Running intltoolize...
Running autoreconf...
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force --warnings=no-portability
autoreconf: configure.ac: tracing
autoreconf: configure.ac: not using Libtool
autoreconf: running: /usr/bin/autoconf --force --warnings=no-portability
autoreconf: running: /usr/bin/autoheader --force --warnings=no-portability
autoreconf: running: automake --add-missing --copy --force-missing --warnings=no-portability
configure.ac:11: installing './compile'
configure.ac:7: installing './install-sh'
configure.ac:7: installing './missing'
Makefile.am: installing './depcomp'
autoreconf: Leaving directory `.'
Running ./configure ...
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking how to create a pax tar archive... gnutar
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking whether make supports nested variables... (cached) yes
checking for valac... valac
configure: WARNING: no proper vala compiler found
configure: WARNING: you will not be able to compile vala source files
checking whether NLS is requested... yes
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.20.2
checking for XML::Parser... ok
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.16... yes
checking for MULTILOADDEPS... yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating data/preferences.ui
config.status: creating data/de.mh21.indicator-multiload.gschema.xml.in
config.status: creating po/Makefile.in
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing po/stamp-it commands

  ------------------------
  indicator-multiload 0.5
  ------------------------
  CPPFLAGS:
  CFLAGS: -g -O2
  LDFLAGS:
  ------------------------

Now type `make' to compile Package

$ make
make all-recursive
make[1]: Verzeichnis „/home/sandro/Downloads/indicator-multiload“ wird betreten
Making all in po
make[2]: Verzeichnis „/home/sandro/Downloads/indicator-multiload/po“ wird betreten
make[2]: *** Keine Regel vorhanden, um das Ziel „af.po“,
  benötigt von „af.gmo“, zu erstellen. Schluss.
make[2]: Verzeichnis „/home/sandro/Downloads/indicator-multiload/po“ wird verlassen
Makefile:945: die Regel für Ziel „all-recursive“ scheiterte
make[1]: *** [all-recursive] Fehler 1
make[1]: Verzeichnis „/home/sandro/Downloads/indicator-multiload“ wird verlassen
Makefile:508: die Regel für Ziel „all“ scheiterte
make: *** [all] Fehler 2

Best Michael Hofmann (mh21) said : #3

Hi Kalsan,

did you use the tar ball or checkout the bzr repository? The tar ball contains the po files, for the bzr checkout you need to merge lp:~indicator-multiload/indicator-multiload/trunk-translations.

Cheers
  Michael

Kalsan (info-kalsan) said : #4

Thank you, this solved my problem. Would maybe be helpful to include this info into the HACKING file :-)

Kalsan (info-kalsan) said : #5

Thanks Michael Hofmann, that solved my question.