the y-axis constantly changes, it's difficult to assess swap or system load

Asked by Adam Wilson on 2011-11-07

The y-axis seems to automatically scale depending on usage. This makes it difficult to assess what's going on. If I look at the disk usage, for example, and the box is full of red it's impossible to know if the i/o is at the maximum, or just that the y axis has scaled the graph such that 5 MB/s fills the box. Is it possible to fix the y axis somehow? My swap box always is 100% purple, even if I'm Swap=0 bytes.

Question information

Language:
English Edit question
Status:
Answered
For:
System Load Indicator Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-07
Last reply:
2013-05-03
Michael Hofmann (mh21) said : #1

Hi Adam,

these are actually a couple of problems :-).

Swap box: this should be fixed in the version in ppa:indicator-multiload/daily.
For the scaling (again in the version in ppa:indicator-multiload/daily): For more advanced settings such as which variables are shown and whether graphs autoscale, open dconf-editor and navigate to /apps/indicators/multiload/.

Hope this helps.

Michael

Nicola Larosa (teknico) said : #2

Hi, I'm affected by this problem too, it's quite annoying. I'm using 0.2-0ubuntu2 on quantal.

I cannot find any autoscale settings in dconf-editor:/apps/indicators/multiload/, nor ones to set the range of the graph.

Thank you.

Michael Hofmann (mh21) said : #3

You need to use the version at ppa:indicator-multiload/stable-daily for this to work.

Felipe (t3chn0k) said : #4

First you said we needed to use ppa:indicator-multiload/daily and now you say we need ppa:indicator-multiload/stable-daily, which one is the right? I really want to fix this scale problem, cause a graph means nothing with no fixed scale.

Thank you.

Felipe (t3chn0k) said : #5

Ok, I got it. Used the PPA ~~/stable-daily. And setted both minimum and maximum values for vertical axe in bytes/second.

Michael Hofmann (mh21) said : #6

Hi Felipe,

Sorry for the confusion. The stable-daily ppa is good enough for this to work. For more bleeding edge versions you can use the daily ppa.

Best regards
  Michael

Felipe (t3chn0k) said : #7

I prefered the cutting-edge version, but I couldn't find "/apps/indicators/multiload/" in dconf to set a fixed vertical axe. So I downgraded to the "stable-daily". Is there a way to set a fixed vertical axe on the "daily" version?

I also would like to thank you, this is a pretty nice applet. :)

Michael Hofmann (mh21) said : #8

Hi Felipe,

oh sorry the dconf path changed to /de/mh21/indicator-multiload/ to conform to the Gnome Guidelines :-).

Best regards
  Michael

Can you help with this problem?

Provide an answer of your own, or ask Adam Wilson for more information if necessary.

To post a message you must log in.