Can not start indicator-cpufreq in terminal and startup application in Ubuntu 11.10

Asked by Charles Lam on 2011-11-30

Fresh install of Ubuntu 11.10 on Intel SU4100 with 2 GB RAM.

Installed by adding PPA and all went ok.

Restart.

No indicator on panel bar.

New item added in "Startup Application" and checked.

Tried to run in Terminal, returns the following error:

Traceback (most recent call last):
  File "/usr/bin/indicator-cpufreq", line 81, in <module>
    ind = MyIndicator()
  File "/usr/lib/python2.7/dist-packages/indicator_cpufreq/indicator.py", line 95, in __init__
    self.update_ui()
  File "/usr/lib/python2.7/dist-packages/indicator_cpufreq/indicator.py", line 106, in update_ui
    fmin, fmax, governor = cpufreq.get_policy(self.cpus[0])
  File "/usr/lib/python2.7/dist-packages/indicator_cpufreq/cpufreq.py", line 143, in get_policy
    policy = (p.contents.min, p.contents.max, p.contents.governor)
ValueError: NULL pointer access

Please help.

Charles.

Question information

Language:
English Edit question
Status:
Answered
For:
indicator-cpufreq Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-30
Last reply:
2012-04-17
Dert Hunter (derthunter) said : #1

I just installed cpufrequtils package and the indicator worked.

sudo apt-get install cpufrequtils

after install cpufrequtils if you cant`t switch to ondemand governator look at this bug in lauchpad, there`s a solution for this:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/432706?comments=all

Can you help with this problem?

Provide an answer of your own, or ask Charles Lam for more information if necessary.

To post a message you must log in.