Can't import basic SRFIs

Asked by Michael S

Using fresh install of cygwin on Windows 7 x64, fresh build of Ikarus, fresh download of SRFIs from launchpad. Not sure if cgywin is 32-bit or if ikarus itself has been compiled as 32-bit. I don't think that's relevant here.

I have IKARUS_LIBRARY_PATH=/usr/local/lib/ikarus/srfi

in this directory are a bunch of %3a0 %3a0.sls, etc files

when i run Ikarus I get errors when I try to import srfi lists, even though library-path shows the correct location. Is there something else I need to do to get this to work? I get similar results on my ubuntu setup.

Thanks a lot

Here is complete transaction from cygwin shell:

mischw@MISCHW4 /usr/local/lib/ikarus/srfi
$ set |grep IKARUS

mischw@MISCHW4 /usr/local/lib/ikarus/srfi
$ ls
%3a0 %3a16.sls %3a27 %3a41.sls %3a64 %3a9.sls
%3a0.sls %3a19 %3a27.sls %3a42 %3a64.sls %3a98
%3a1 %3a19.sls %3a31 %3a42.sls %3a67 %3a98.sls
%3a1.sls %3a2 %3a31.sls %3a43 %3a67.sls %3a99
%3a11 %3a2.sls %3a37 %3a43.sls %3a69 %3a99.sls
%3a11.sls %3a23 %3a37.sls %3a48 %3a69.sls LICENSE
%3a13 %3a23.sls %3a38 %3a48.sls %3a78 README
%3a13.sls %3a25 %3a38.sls %3a6 %3a78.sls compile-all.ikarus.sps
%3a14 %3a25.sls %3a39 %3a6.sls %3a8 private
%3a14.sls %3a26 %3a39.sls %3a61 %3a8.sls tests
%3a16 %3a26.sls %3a41 %3a61.sls %3a9

mischw@MISCHW4 /usr/local/lib/ikarus/srfi
$ ikarus
Ikarus Scheme version 0.0.3
Copyright (c) 2006-2008 Abdulaziz Ghuloum

> (import (srfi lists))
Unhandled exception
 Condition components:
   1. &error
   2. &who: expander
   3. &message: "cannot locate library in library-path"
   4. &library-resolution:
       library: (srfi lists)
       files: ("./srfi/lists.ikarus.sls" "./srfi/" "./srfi/lists.
ikarus.scm" "./srfi/lists.sls" "./srfi/" "./srfi/lists.scm" "/usr/local/
lib/ikarus/srfi/srfi/lists.ikarus.sls" "/usr/local/lib/ikarus/srfi/srfi/lists.ik" "/usr/local/lib/ikarus/srfi/srfi/lists.ikarus.scm" "/usr/local/lib/ikar
us/srfi/srfi/lists.sls" "/usr/local/lib/ikarus/srfi/srfi/" "/usr/local/l
ib/ikarus/srfi/srfi/lists.scm" "/usr/local/lib/ikarus/srfi/lists.ikarus.sls" "/u
sr/local/lib/ikarus/srfi/" "/usr/local/lib/ikarus/srfi/lists.ikar
us.scm" "/usr/local/lib/ikarus/srfi/lists.sls" "/usr/local/lib/ikarus/srfi/lists
.ss" "/usr/local/lib/ikarus/srfi/lists.scm")

("." "/usr/local/lib/ikarus/srfi" "/usr/local/lib/ikarus")

Question information

English Edit question
Ikarus Scheme Edit question
No assignee Edit question
Solved by:
Michael S
Last query:
Last reply:
Revision history for this message
Michael S (q4vqrr54ns) said :

Hi, an update: I bzr'ed the latest ikarus source code (version 0.0.4-rc1+) and that seems to have fixed the problem.

Now I'm learning the system and finding that a lot of SRFI stuff is already found in the basic libs, but not fully. for example hashtable, etc.