Linking Compentecies to Training Courses in version 3.1.2 & Upgrade notes to 4.0

Asked by ehr on 2009-07-17

Hello,

My add Training Course Form does not have a Select Competencies field despite the fact that it is enable/checked in the modules. Am using version 3.1.3. How do I make this field show up.

Also is there upgrade documents for prior version to version 4.0. I have a lot of custom fields and how will the new version affect me.

Kind regards

Chanda

Question information

Language:
English Edit question
Status:
Solved
For:
iHRIS Manage Edit question
Assignee:
No assignee Edit question
Solved by:
ehr
Solved:
2009-08-23
Last query:
2009-08-23
Last reply:
2009-07-18
ehr (chanda-lusakatimes) said : #1

Just seen this in the

Some bugs remain in the In-Service Training Management Module, specifically with regard to associating competencies with training courses. This module is disabled by default for this release. If you are using this module, we recommend that you wait until the update is released before upgrading. The known bugs are scheduled to be corrected in our next minor release, Version 4.0.1.

Did this bug affect 3.1.3 as well?

Carl Leitner (litlfred) said : #2

We have one document that describes the steps taken for an upgrade from 3.1 to 4.0 for one
of our customizations. There was not too much to do.
  http://open.intrahealth.org/mediawiki/Tutorial:_Upgrading_From_3.1

Most of the changes from 3.1 to 4.0 have occurred in the back-end to enable decentralized
data management as well as to maintain centralized lists of data, in particular we added different
form storage mechanisms:
 http://open.intrahealth.org/mediawiki/Technical_Overview:_Form_Storage_Mechanisms

Another large change was that iHRIS Manage was broken up
into many smaller modules. Some of these modules now reside as sub-module of ihris-common
and some as sub-modules of ihris-manage.

The final major change (that I can think of at the moment) is that we now have added <version>
tags to the configuration data stored in the config.xml files for a module.
 http://open.intrahealth.org/mediawiki/Technical_Overview:_Configuration_(Magic)_Data#.3Cversion.3E

If your customizations are available somewhere, we would be happy to help you review
the code and make the upgrade.

ehr (chanda-lusakatimes) said : #3

will wait for version 4.01