how to solve this issue: on iHRIS on the file mysql.php lmaximun excution exceed 30

Asked by josephat mathayo on 2009-03-23

When i open iHRIS, It gives out the message of MAXIMUM EXCUTION EXCEED 30 in /usr/share/php/MDB2/Driver/mysql.php

Question information

Language:
English Edit question
Status:
Answered
For:
iHRIS Manage Edit question
Assignee:
No assignee Edit question
Last query:
2009-03-23
Last reply:
2009-03-25
Carl Leitner (litlfred) said : #1

The appliance does not have a good enough processor at the moment and it is probably running out of time when it is cache the database and building the reports. One easy fix is to edit:
  /etc/php5/apache2/php.ini
look for the
  max_execution_time = 30
and change it to
  max_execution_time = 300
I would also make double-check that the "Background Process" module is enabled by looking under "Configure System"->"Configure Modules."

The other reason that this could be happening if some of the modules configuration files have been changed. If you are changing a module's configuration file and keep seeing this error, you may want to start upgrade the module reconfiguration from the command line rather than through the web browser. To do this:
  cd /var/www/iHRIS/manage
  php index.php

Can you help with this problem?

Provide an answer of your own, or ask josephat mathayo for more information if necessary.

To post a message you must log in.