Failing system update. Required module I2CE could not be enabled/upgraded.

Asked by Kayode Odusote on 2011-04-30

After successful installation and logout, then
shutdown the system, the next time I restart the system and open the
site, I get a message to update the site. Then it begins a new
installation which fails to install with the message "Required module I2CE could not be enabled/upgraded". If I delete the database in mysql and recreate it, I am able to successfully install it again. Below is
the terminal log from one of such instances.

[Sat Apr 30 11:04:30 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:244)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Beginning new installation
[Sat Apr 30 11:04:30 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:249)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Site module is: ihris-manage-mali-site
[Sat Apr 30 11:04:30 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:255)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Enabling I2CE
[Sat Apr 30 11:04:30 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:256)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Setting site module to ihris-manage-mali-site
[Sat Apr 30 11:04:30 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:443)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Updating Modules
[Sat Apr 30 11:04:30 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:462)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Will attempt to update:
               Updates:
                       I2CE
[Sat Apr 30 11:04:30 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:468)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Site is set at config to be ihris-manage-mali-site
[Sat Apr 30 11:04:35 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:718)
             I2CE_Configurator->checkRequirements
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:470)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Done looking for available config files. Available:
               I2CE,ihris-common,ihris-manage,ihris-qualify,textlayout,ihris-manage-mali-site,user,MooTools,forms,MimeTypes,i2ce-site,Timer,YAML_spyc,CustomReports,jumper,template-data,maani-charts,magicDataExport,BackgroundProcess,swissfactory,messageHandler,ImportExport,pages,UserAccess_DHIS,UserAccess,UserAccess_LDAP,UserAccess_LDAP_Hybrid,DatePicker,MooTools-I2CE,menu_select,ColorPicker,FormWorm,StretchPage,TreeSelect,fancyDebug,ReferenceField,LocaleForm,Float,form-limits,BinField,formBrowser,formDocumentor,UserForm,forms-storage,Fields,Lists,field-limits,CachedForms,PrintedForms,formRelationships,forms-storage-entry,forms-storage-SDMXHD,forms-storage-magicdata,forms-storage-eval,forms-storage-file,forms-storage-multiflat,forms-storage-xml,forms-storage-CSV,forms-storage-flat,Lists-LinkTo,Lists-LinkTo-List,Lists-LinkTo-String,CustomReports_Export,ReportArchiver,CustomReports_PDF,CustomReports-Selector,CustomReports_PieChart,Tags,DisplayData,Options,swissMagic,swissConfig,messageBox,messageNotice,localeSelector,modDocumentor,admin,FileDump,stub,magicDataBrowser,LoginPage,tasks-roles,exportReport,modulePrompter,deleteRecord,training-institution,CEUs,ihris-common-Search,SDMX-HD-CodeLists,Person,UUID_map,ihris-common-RecentForm,ihris-common-Job,establishment,simple-competency,Photo,Contact,Currency,Geography,Document,ihris-common-Cadre,SampleData-Common,Facility,training-course,PersonEmployment,person-simple-competency,PersonDemographic,RecordStatus,PersonLanguage,PersonResume,PersonID,PersonArchivedScan,PersonPassportPhoto,nextOfKin,dependents,PersonContact,PersonNotes,PersonEducation,isco-88,isco-08,isco-88-major-05,isco-88-major-09,isco-88-major-04,isco-88-major-07,isco-88-major-03,isco-88-major-00,isco-88-major-06,isco-88-major-01,isco-88-major-02,isco-88-major-08,isco-08-major-00,isco-08-major-02,isco-08-major-05,isco-08-major-03,isco-08-major-01,isco-08-major-07,isco-08-major-04,isco-08-major-09,isco-08-major-06,isco-08-major-08,SampleData-Geography,SampleData-edu_type,SampleData-currency,SampleData-degree,SampleData-district,SampleData-country,SampleData-county,SampleData-region,FacilityContact,training-simple-competency,training-exam,ihris-manage-PersonDemographic,disciplinary_action,ihris-manage-PersonPosition,ihris-manage-CustomReports,accident,ihris-manage-Person,ihris-manage-help,ihris-manage-base-data,ihris-manage-sample-data,ihris-manage-Job,ihris-manage-confirmation,ManageRegistration,manage-training-course,ihris-manage-medical-data,ihris-manage-Benefit,ihris-manage-Application,ihris-manage-Salary,ihris-manage-CustomReports-FilledPositions,ihris-manage-CustomReports-facility-reports,ihris-manage-CustomReports-staff-reports,ihris-manage-CustomReports-search-people,ihris-manage-CustomReports-position-reports,SampleData-benefit_type,SampleData-accident_type,SampleData-marital_status,SampleData-pos_change_reason,SampleData-id_type,SampleData-language,SampleData-establishment,SampleData-facility,SampleData-confirmation_type,ihris-manage-ConfirmationAttachment,manage-training-simple-competency,manage-training-institution,SampleData-job,SampleData-cadre,SampleData-council,SampleData-classification,SampleData-department,SampleData-training_course_requestor,SampleData-disciplinary_action_type,SampleData-competency_type,SampleData-competency,SampleData-salary_grade,SampleData-position_type,SampleData-training_course_category,SampleData-salary_source,SampleData-facility_type,ihris-manage-ApplicationAttachment,RecordVerify,ihris-qualify-base-data,ihris-qualify-sample-data,ihris-qualify-help,ihris-qualify-PrintedForms,ihris-qualify-CustomReports,QualifySampleData-marital_status,QualifySampleData-id_type,QualifySampleData-facility_type,QualifySampleData-verify_change,ihris-qualify-PrintedForms-license,ihris-qualify-PrintedForms-registration,ihris-qualify-CustomReports-institution,ihris-qualify-CustomReports-person,ihris-qualify-CustomReports-license,ihris-qualify-CustomReports-search-training,ihris-qualify-CustomReports-disruption,ihris-qualify-CustomReports-search-people,ihris-qualify-CustomReports-exam,ihris-qualify-CustomReports-training,ihris-qualify-CustomReports-registration,tcpdf,Mali-education,Mali-training-history,Mali-deployment-history,Mali-promotion-history,Mali-salary,Mali-dependents,Mali-person,Mali-national-honours,Mali-facility,Mali-retirement,Mali-contact,Mali-demographic
[Sat Apr 30 11:04:35 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:795)
             I2CE_Configurator->checkRequirements
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:470)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Making main dependecy tree for:
               I2CE
[Sat Apr 30 11:04:35 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:801)
             I2CE_Configurator->checkRequirements
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:470)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Not optional I2CE
[Sat Apr 30 11:04:35 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:824)
             I2CE_Configurator->checkRequirements
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:470)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Update I2CE adds the following additional required modules:
               I2CE
[Sat Apr 30 11:04:35 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:836)
             I2CE_Configurator->checkRequirements
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:470)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Required modules are=I2CE
[Sat Apr 30 11:04:35 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:580)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Attempting to update/enable the following out of date modules: I2CE
[Sat Apr 30 11:04:35 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:584)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       The following modules class paths are being added:
[Sat Apr 30 11:04:35 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:885)
             I2CE_Updater->loadModuleMagicData
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:716)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Previously processed config data for I2CE with version <= 0. New
version is 4.0.13.0
[Sat Apr 30 11:04:35 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:497)
             I2CE_Configurator->processConfig
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:904)
             I2CE_Updater->loadModuleMagicData
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:716)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Processing config for (I2CE) with version (0)
[Sat Apr 30 11:04:35 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:500)
             I2CE_Configurator->processConfig
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:904)
             I2CE_Updater->loadModuleMagicData
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:716)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Reading in config values for version >= 0
[Sat Apr 30 11:04:35 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:922)
             I2CE_Updater->loadModuleMagicData
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:716)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Loaded in magic data for I2CE to memory
[Sat Apr 30 11:04:35 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_ModuleFactory.php:606)
             I2CE_ModuleFactory->enable
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:931)
             I2CE_Updater->preUpgradeModule
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:726)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Enabling/updating I2CE
[Sat Apr 30 11:04:36 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_ModuleFactory.php:328)
             I2CE_ModuleFactory->updateHooks
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_ModuleFactory.php:618)
             I2CE_ModuleFactory->enable
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:931)
             I2CE_Updater->preUpgradeModule
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:726)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Updating hooks/methods for I2CE
[Sat Apr 30 11:04:36 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_ModuleFactory.php:621)
             I2CE_ModuleFactory->enable
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:931)
             I2CE_Updater->preUpgradeModule
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:726)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Initializing I2CE
[Sat Apr 30 11:04:36 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->pearError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Module_Core.php:144)
             I2CE_Module_Core->createAltConfig
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Module_Core.php:53)
             I2CE_Module_Core->action_initialize
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_ModuleFactory.php:623)
             I2CE_ModuleFactory->enable
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:931)
             I2CE_Updater->preUpgradeModule
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:726)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Cannot access database:
       MDB2 Error: connect failed
       _doConnect: [Error message: Access denied for user
'ihris'@'localhost' (using password: YES)]
       [Native code: 1045]
       [Native message: Access denied for user 'ihris'@'localhost' (using
password: YES)]
[Sat Apr 30 11:04:36 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_ModuleFactory.php:624)
             I2CE_ModuleFactory->enable
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:931)
             I2CE_Updater->preUpgradeModule
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:726)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Initialization for I2CE failed
[Sat Apr 30 11:04:36 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:932)
             I2CE_Updater->preUpgradeModule
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:726)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Could not enable I2CE
[Sat Apr 30 11:04:36 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:774)
             I2CE_Updater->failedRequiredUpdate
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:727)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Failing on module I2CE: Could not pre-update module
[Sat Apr 30 11:04:36 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_MagicDataStorageAPC.php:226)
             I2CE_MagicDataStorageAPC->clear
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_MagicData.php:176)
             I2CE_MagicData->clearCache
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:776)
             I2CE_Updater->failedRequiredUpdate
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:727)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Clearing all keys from APC with prefix I2CE_MD_manage_mali_4_0_config_data_
[Sat Apr 30 11:04:36 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:792)
             I2CE_Updater->failedRequiredUpdate
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:727)
             I2CE_Updater->_updateModules
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Required module I2CE could not be enabled/upgraded. Failing system update
[Sat Apr 30 11:04:36 2011] [error] [client 127.0.0.1]
       Refered by : http://localhost/mali-manage/
       I2CE: I2CE->raiseError
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:262)
             I2CE_Updater->install
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
             I2CE_Updater->_updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
             I2CE_Updater->updateSite
(/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
             I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Installation Failed for I2CE

I wonder if anyone can give
me a clue as to what is happening and what can be done.

Question information

Language:
English Edit question
Status:
Answered
For:
iHRIS Manage Edit question
Assignee:
No assignee Edit question
Last query:
2011-04-30
Last reply:
2011-05-03
josephat mathayo (jmathayo) said : #1

It can be php, which version are running? can you try to do:
localhost/manage/index.php?update.php

Run the apache_tail then post the result

You may be right.

I had problem installing an earlier version of php-apc following the instructions on installing iHRIS on Ubuntu 10.4. It kept giving an error which I could not resolve. So I guess the system is still using the php5 that came with Ubuntu 10.10. I would try to reinstall the older version of php-apc. I hope I succeed and I hope that would solve the problem.

I'll keep you all informed.

Still unable to install older version of php-apc:

kayodu@kayodu-1005HA:~$ sudo apt-get install php-apc
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.35-22 linux-headers-2.6.35-22-generic
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  php-apc
0 upgraded, 1 newly installed, 0 to remove and 8 not upgraded.
Need to get 0B/61.0kB of archives.
After this operation, 209kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  php-apc
Install these packages without verification [y/N]? y
(Reading database ... 155986 files and directories currently installed.)
Unpacking php-apc (from .../php-apc_3.1.7-2chl1~maverick1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/php-apc_3.1.7-2chl1~maverick1_i386.deb (--unpack):
 trying to overwrite '/usr/lib/php5/20090626+lfs/apc.so', which is also in package php5-apc 3.1.6-2chl1~maverick1
Errors were encountered while processing:
 /var/cache/apt/archives/php-apc_3.1.7-2chl1~maverick1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
kayodu@kayodu-1005HA:~$

Any suggestions?

Using the synaptic package manager, I uninstalled php5-apc and installed php-apc. This has not resolved the problem. Below is the tail_php 0 output:

[Tue May 03 10:22:25 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:244)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Beginning new installation
[Tue May 03 10:22:25 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:249)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Site module is: ihris-manage-mali-site
[Tue May 03 10:22:25 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:255)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Enabling I2CE
[Tue May 03 10:22:25 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:256)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Setting site module to ihris-manage-mali-site
[Tue May 03 10:22:25 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:443)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Updating Modules
[Tue May 03 10:22:25 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:462)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Will attempt to update:
  Updates:
   I2CE
[Tue May 03 10:22:25 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:468)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Site is set at config to be ihris-manage-mali-site
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:718)
       I2CE_Configurator->checkRequirements (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:470)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Done looking for available config files. Available:
  I2CE,ihris-common,ihris-manage,ihris-qualify,textlayout,ihris-manage-mali-site,user,MooTools,forms,MimeTypes,i2ce-site,Timer,YAML_spyc,CustomReports,jumper,template-data,maani-charts,magicDataExport,BackgroundProcess,swissfactory,messageHandler,ImportExport,pages,UserAccess_DHIS,UserAccess,UserAccess_LDAP,UserAccess_LDAP_Hybrid,DatePicker,MooTools-I2CE,menu_select,ColorPicker,FormWorm,StretchPage,TreeSelect,fancyDebug,ReferenceField,LocaleForm,Float,form-limits,BinField,formBrowser,formDocumentor,UserForm,forms-storage,Fields,Lists,field-limits,CachedForms,PrintedForms,formRelationships,forms-storage-entry,forms-storage-SDMXHD,forms-storage-magicdata,forms-storage-eval,forms-storage-file,forms-storage-multiflat,forms-storage-xml,forms-storage-CSV,forms-storage-flat,Lists-LinkTo,Lists-LinkTo-List,Lists-LinkTo-String,CustomReports_Export,ReportArchiver,CustomReports_PDF,CustomReports-Selector,CustomReports_PieChart,Tags,DisplayData,Options,swissMagic,swissConfig,messageBox,messageNotice,localeSelector,modDocumentor,admin,FileDump,stub,magicDataBrowser,LoginPage,tasks-roles,exportReport,modulePrompter,deleteRecord,training-institution,CEUs,ihris-common-Search,SDMX-HD-CodeLists,Person,UUID_map,ihris-common-RecentForm,ihris-common-Job,establishment,simple-competency,Photo,Contact,Currency,Geography,Document,ihris-common-Cadre,SampleData-Common,Facility,training-course,PersonEmployment,person-simple-competency,PersonDemographic,RecordStatus,PersonLanguage,PersonResume,PersonID,PersonArchivedScan,PersonPassportPhoto,nextOfKin,dependents,PersonContact,PersonNotes,PersonEducation,isco-88,isco-08,isco-88-major-05,isco-88-major-09,isco-88-major-04,isco-88-major-07,isco-88-major-03,isco-88-major-00,isco-88-major-06,isco-88-major-01,isco-88-major-02,isco-88-major-08,isco-08-major-00,isco-08-major-02,isco-08-major-05,isco-08-major-03,isco-08-major-01,isco-08-major-07,isco-08-major-04,isco-08-major-09,isco-08-major-06,isco-08-major-08,SampleData-Geography,SampleData-edu_type,SampleData-currency,SampleData-degree,SampleData-district,SampleData-country,SampleData-county,SampleData-region,FacilityContact,training-simple-competency,training-exam,ihris-manage-PersonDemographic,disciplinary_action,ihris-manage-PersonPosition,ihris-manage-CustomReports,accident,ihris-manage-Person,ihris-manage-help,ihris-manage-base-data,ihris-manage-sample-data,ihris-manage-Job,ihris-manage-confirmation,ManageRegistration,manage-training-course,ihris-manage-medical-data,ihris-manage-Benefit,ihris-manage-Application,ihris-manage-Salary,ihris-manage-CustomReports-FilledPositions,ihris-manage-CustomReports-facility-reports,ihris-manage-CustomReports-staff-reports,ihris-manage-CustomReports-search-people,ihris-manage-CustomReports-position-reports,SampleData-benefit_type,SampleData-accident_type,SampleData-marital_status,SampleData-pos_change_reason,SampleData-id_type,SampleData-language,SampleData-establishment,SampleData-facility,SampleData-confirmation_type,ihris-manage-ConfirmationAttachment,manage-training-simple-competency,manage-training-institution,SampleData-job,SampleData-cadre,SampleData-council,SampleData-classification,SampleData-department,SampleData-training_course_requestor,SampleData-disciplinary_action_type,SampleData-competency_type,SampleData-competency,SampleData-salary_grade,SampleData-position_type,SampleData-training_course_category,SampleData-salary_source,SampleData-facility_type,ihris-manage-ApplicationAttachment,RecordVerify,ihris-qualify-base-data,ihris-qualify-sample-data,ihris-qualify-help,ihris-qualify-PrintedForms,ihris-qualify-CustomReports,QualifySampleData-marital_status,QualifySampleData-id_type,QualifySampleData-facility_type,QualifySampleData-verify_change,ihris-qualify-PrintedForms-license,ihris-qualify-PrintedForms-registration,ihris-qualify-CustomReports-institution,ihris-qualify-CustomReports-person,ihris-qualify-CustomReports-license,ihris-qualify-CustomReports-search-training,ihris-qualify-CustomReports-disruption,ihris-qualify-CustomReports-search-people,ihris-qualify-CustomReports-exam,ihris-qualify-CustomReports-training,ihris-qualify-CustomReports-registration,tcpdf,Mali-education,Mali-training-history,Mali-deployment-history,Mali-promotion-history,Mali-salary,Mali-dependents,Mali-person,Mali-national-honours,Mali-facility,Mali-retirement,Mali-contact,Mali-demographic
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:795)
       I2CE_Configurator->checkRequirements (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:470)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Making main dependecy tree for:
  I2CE
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:801)
       I2CE_Configurator->checkRequirements (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:470)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Not optional I2CE
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:824)
       I2CE_Configurator->checkRequirements (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:470)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Update I2CE adds the following additional required modules:
  I2CE
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:836)
       I2CE_Configurator->checkRequirements (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:470)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Required modules are=I2CE
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:580)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Attempting to update/enable the following out of date modules: I2CE
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:584)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 The following modules class paths are being added:
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:885)
       I2CE_Updater->loadModuleMagicData (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:716)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Previously processed config data for I2CE with version <= 0. New version is 4.0.13.0
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:497)
       I2CE_Configurator->processConfig (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:904)
       I2CE_Updater->loadModuleMagicData (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:716)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Processing config for (I2CE) with version (0)
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Configurator.php:500)
       I2CE_Configurator->processConfig (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:904)
       I2CE_Updater->loadModuleMagicData (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:716)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Reading in config values for version >= 0
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:922)
       I2CE_Updater->loadModuleMagicData (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:716)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Loaded in magic data for I2CE to memory
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_ModuleFactory.php:606)
       I2CE_ModuleFactory->enable (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:931)
       I2CE_Updater->preUpgradeModule (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:726)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Enabling/updating I2CE
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_ModuleFactory.php:328)
       I2CE_ModuleFactory->updateHooks (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_ModuleFactory.php:618)
       I2CE_ModuleFactory->enable (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:931)
       I2CE_Updater->preUpgradeModule (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:726)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Updating hooks/methods for I2CE
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_ModuleFactory.php:621)
       I2CE_ModuleFactory->enable (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:931)
       I2CE_Updater->preUpgradeModule (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:726)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Initializing I2CE
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->pearError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Module_Core.php:144)
       I2CE_Module_Core->createAltConfig (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Module_Core.php:53)
       I2CE_Module_Core->action_initialize (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_ModuleFactory.php:623)
       I2CE_ModuleFactory->enable (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:931)
       I2CE_Updater->preUpgradeModule (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:726)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Cannot access database:
 MDB2 Error: connect failed
 _doConnect: [Error message: Access denied for user 'ihris'@'localhost' (using password: YES)]
 [Native code: 1045]
 [Native message: Access denied for user 'ihris'@'localhost' (using password: YES)]
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_ModuleFactory.php:624)
       I2CE_ModuleFactory->enable (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:931)
       I2CE_Updater->preUpgradeModule (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:726)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Initialization for I2CE failed
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:932)
       I2CE_Updater->preUpgradeModule (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:726)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Could not enable I2CE
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:774)
       I2CE_Updater->failedRequiredUpdate (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:727)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Failing on module I2CE: Could not pre-update module
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_MagicDataStorageAPC.php:226)
       I2CE_MagicDataStorageAPC->clear (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_MagicData.php:176)
       I2CE_MagicData->clearCache (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:776)
       I2CE_Updater->failedRequiredUpdate (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:727)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Clearing all keys from APC with prefix I2CE_MD_manage_mali_4_0_config_data_
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:792)
       I2CE_Updater->failedRequiredUpdate (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:727)
       I2CE_Updater->_updateModules (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:260)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Required module I2CE could not be enabled/upgraded. Failing system update
[Tue May 03 10:22:31 2011] [error] [client ::1]
 Refered by : http://localhost/mali-manage/index.php/update.php
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:262)
       I2CE_Updater->install (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:156)
       I2CE_Updater->_updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE_Updater.php:100)
       I2CE_Updater->updateSite (/var/lib/iHRIS/lib/4.0.13/I2CE/lib/I2CE.php:600)
       I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
 Installation Failed for I2CE

It appears to me that the problem is finding the password for the MySQL database that should have been stored in magicdata storage. When the database is created or re-created, there is no problem in installation. After the initial installation, future attempts to open the site starts an update session (automatically) and this fails as it is unable to access the database. I think it is more than a problem with the php-apc.

Carl Leitner (litlfred) said : #5

Dear Kayode,
 This bit:
         I2CE->initializeDSN (/var/lib/iHRIS/mali/4.0/pages/index.php:49)
       Cannot access database:
       MDB2 Error: connect failed
       _doConnect: [Error message: Access denied for user 'ihris'@'localhost' (using password: YES)]
       [Native code: 1045]
       [Native message: Access denied for user 'ihris'@'localhost' (using password: YES)]

tells us that there is a problem in connecting to the database. It could be a typo in the mysql username, password, or database name. It could also be that the database does not exist or that the mysql user (ihris) does not have access to the database

Can you help with this problem?

Provide an answer of your own, or ask Kayode Odusote for more information if necessary.

To post a message you must log in.