GT-200e ?

Asked by bikeham on 2009-10-05

I just bought a GT-200e and am keen to try it out. I am using os x and 0.2.93 but get -1 returned from the device when I try to download the waypoints.

Is the software compatible with my model or am I doing something wrong?

Question information

Language:
English Edit question
Status:
Answered
For:
igotu2gpx Edit question
Assignee:
No assignee Edit question
Last query:
2009-10-05
Last reply:
2009-10-05
Michael Hofmann (mh21) said : #1

Thanks for your question.

Normally it should work, but the USB connection is a bit sensitive. Could you please try the steps outlined at https://answers.launchpad.net/igotu2gpx/+faq/714 and report whether they help?

bikeham (stevenj-fastmail) said : #2

Hi Michael,

thanks for your prompt reply. I am not sure if the command line
version is installed, I get this:

bikeham:~ stevenjackson$ IGOTU2GPX_WORKAROUND=enabled igotu2gpx -v info
-bash: igotu2gpx: command not found
bikeham:~ stevenjackson$

Cheers,

Steve

On 05/10/2009, at 6:37 PM, Michael Hofmann wrote:

> Your question #84816 on igotu2gpx changed:
> https://answers.edge.launchpad.net/igotu2gpx/+question/84816
>
> Status: Open => Needs information
>
> Michael Hofmann requested for more information:
> Thanks for your question.
>
> Normally it should work, but the USB connection is a bit sensitive.
> Could you please try the steps outlined at
> https://answers.launchpad.net/igotu2gpx/+faq/714 and report whether
> they
> help?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.edge.launchpad.net/igotu2gpx/+question/84816
>
> You received this question notification because you are a direct
> subscriber of the question.

Michael Hofmann (mh21) said : #3

Normally, the use of IGOTU2GPX_WORKAROUND shouldn't be necessary (it is only if you get hangs, not connection errors). But it should be installed, in /Applications/igotu2gpx.app/Contents/MacOS or sth. similar.

These errors are caused by problems with the USB connection, and are quite hardware-specific (mostly caused by USB hubs), so stuff like
- connect the GPS tracker directly to a USB port of your PC, do not use a USB hub
- make sure that the blue LED of the GPS tracker is blinking continuously before you plug it in
- unplug the tracker, wait 2 seconds and plug it in again (this is often necessary after there were communication errors with the GPS tracker)
are the best I can come up with.

bikeham (stevenj-fastmail) said : #4

I plug it in, the red and blue lights are both on. I press the button
on the i-gotu and blue light flashes.

I run igotu2gpx and this is returned:

Serial number: 254239
Firmware version: 3.09
Model: GT-200e
Number of points: 66
Schedule date: 17 August 2009
Schedule date offset: 0 day(s)
Schedule table: disabled
Log interval: 5 s
Interval change: disabled
LEDs: enabled
Button: enabled
Security version: 0
Password: disabled, []

Unable to download trackpoints from GPS tracker: Device responded with
error code: -1

I am plugging it in directly into my iMac running Snow Leopard.

Steve

On 05/10/2009, at 7:45 PM, Michael Hofmann wrote:

> Your question #84816 on igotu2gpx changed:
> https://answers.edge.launchpad.net/igotu2gpx/+question/84816
>
> Status: Open => Answered
>
> Michael Hofmann proposed the following answer:
> Normally, the use of IGOTU2GPX_WORKAROUND shouldn't be necessary (it
> is
> only if you get hangs, not connection errors). But it should be
> installed, in /Applications/igotu2gpx.app/Contents/MacOS or sth.
> similar.
>
> These errors are caused by problems with the USB connection, and are
> quite hardware-specific (mostly caused by USB hubs), so stuff like
> - connect the GPS tracker directly to a USB port of your PC, do not
> use a USB hub
> - make sure that the blue LED of the GPS tracker is blinking
> continuously before you plug it in
> - unplug the tracker, wait 2 seconds and plug it in again (this is
> often necessary after there were communication errors with the GPS
> tracker)
> are the best I can come up with.
>
> --
> If this answers your question, please go to the following page to
> let us
> know that it is solved:
> https://answers.edge.launchpad.net/igotu2gpx/+question/84816/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.edge.launchpad.net/igotu2gpx/+question/84816
>
> You received this question notification because you are a direct
> subscriber of the question.

Michael Hofmann (mh21) said : #5

I created a new bug for this, could you run it with "igotu2gpx -v" and add the output as an attachment to https://bugs.edge.launchpad.net/igotu2gpx/+bug/442962?

Can you help with this problem?

Provide an answer of your own, or ask bikeham for more information if necessary.

To post a message you must log in.