0.2.92-1~hardy1 from PPA repository does not work

Asked by Sciamano on 2009-09-30

Hello, it's me again.
I've put my hands on a GT-200e, and was trying it with igotu2gpx.
I've installed the new version (0.2.92-1~hardy) via the PPA repository, but the GUI won't launch.
Here is the error:

---------begin-------
luca@desktop:~$ igotugui
QFSFileEngine::open: No file name specified
Cannot open file '', because: No file name specified
cannot open "" for reading
fstat error
mmap error for input
Segmentation fault
-------end--------

Also, the command igotu2gpx --version gives:

-------begin--------
Igotu2gpx 0.2.91
Downloads tracks and waypoints from MobileAction i-gotU USB GPS travel loggers.

Copyright (C) 2009 Michael Hofmann.
License GPLv3+: GNU GPL version 3 or later (http://gnu.org/licenses/gpl.html)
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
------end------

I expected to see 0.2.92, or was I expecting wrong?

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
igotu2gpx Edit question
Assignee:
No assignee Edit question
Solved by:
Sciamano
Solved:
2009-10-02
Last query:
2009-10-02
Last reply:
2009-10-02
Michael Hofmann (mh21) said : #1

I think there is something else wrong. I checked the hardy package, it has the correct version identifier. Maybe you are using the wrong executable from /usr/local/bin or ~/bin? Can you do 'which igotu2gpx'? The segmentation fault is weird, but maybe it is related to the wrong version.

Sciamano (sciamano72) said : #2

I uninstalled the previous version (compiled from source) with 'sudo make uninstall' before installing the version from the repository, therefore there shouldn't be a problem with wrong executables...
To be sure, I've also purged the package and reinstalled.

This is the situation now:

'which igotu2gpx' outputs: /usr/bin/igotu2gpx

'igotu2gpx --version' outputs: Igotu2gpx 0.2.92 (this is now correct)

'igotugui' still outputs:

QFSFileEngine::open: No file name specified
Cannot open file '', because: No file name specified
cannot open "" for reading
fstat error
mmap error for input
Segmentation fault

Michael Hofmann (mh21) said : #3

Ok, this solved part of the problem. Could you delete /usr/lib/igotu2gpx/libmarblevisualizer.so and try again? And please start it in a debugger with "gdb igotugui" and run it ("r"). When it crashes, get a backtrace ("bt") and post it here.

Sciamano (sciamano72) said : #4

Ok, I deleted the file and launched igotugui. It now launches, although it won't recognize the GT200e (error -1).
I tried turning it on before plugging the device, and this time I got really scared because I got a protocol error, and when I unplugged the device it wouldn't respond to any press of the button (no red led, no blue led, no blinking, nothing).
I had to reset it with @tripPC and now it works again...

Michael Hofmann (mh21) said : #5

Ok, so the problem seems to be caused by a problem with the marble installation (which is used to display openstreetmap). Could you post the output of "dpkg -l '*marble*'"?

Most of the connection errors are just this: connection errors. The program expects a certain response format when it sends commands, and complains if sth. unexpected (no/wrong response) happens. This is mostly caused by the USB connection stuff, which is more or less stable depending on the hardware, USB hubs inbetween etc.

As far as I know is @tripPC not doing anything different, although their USB support seems a bit more stable.

If you feel brave and while trying again you have the same problem, try to see whether just plugging/unplugging the tracker would bring it back to life (it always works for me, but I also only have one GT120 and one laptop+PC, so that's not very representative).

I amended https://answers.edge.launchpad.net/igotu2gpx/+faq/714 with the stuff about plugging/unplugging the tracker.

All trackers respond to the same wire protocol, so the GT200e shouldn't be any different from the other trackers.

Michael Hofmann (mh21) said : #6

Oh, and thanks to the kind support of Eric Lu from MobileAction, I should get a GT200e next week, so I hope I will be able to sort out any issues that might exist.

Sciamano (sciamano72) said : #7

Hi Michael,
here is the output requested:

luca@desktop:~$ dpkg -l '*marble*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-================-================-================================================
ii libmarble4-kde4 4:4.0.3-0ubuntu1 library for Marble
ii marble-data 0.4.3-2 data files for Marble
un marble-data-kde4 <none> (no description available)

Regarding the plugging/unplugging, I tried that but the logger did not 'come to life' again. Also, I don't use a usb hub but connect directly to the USB sockets of the PC.
I've just tried again and everything worked. I guess connection problems just come and go...

Michael Hofmann (mh21) said : #8

Heh thanks. That is actually a packaging bug on Hardy and it will be fixed in the next release candidate. If you want a map to see the waypoints, reinstall igotu2gpx so that you get a libmarblevisualizer.so again, and then install marble-data-kde4 which should help with the crash.

Sciamano (sciamano72) said : #9

Thanks for the reply, Michael.
I currently don't need to see the waypoints on an openstreetmap, so no problem with that.
I will patiently wait for the next RC. :-)