igotu2gpx 02.2 Error Unable to connect to gps tracker: Unable to connect via connection

Asked by Paul Clegg on 2009-06-12

Hello

The gui displays but I get the following error when choosing info

Unable to connect to gps tracker: Unable to connect via connection

Running on Ubuntu Jaunty

Output from lsusb command

Bus 001 Device 002: ID 0db0:4011 Micro Star International Medion Flash XL V2.0 Card Reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 04b4:8328 Cypress Semiconductor Corp.
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 004: ID 0df7:0900 Mobile Action Technology, Inc.
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Question information

Language:
English Edit question
Status:
Solved
For:
igotu2gpx Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Hofmann
Solved:
2009-06-16
Last query:
2009-06-16
Last reply:
2009-06-16
Michael Hofmann (mh21) said : #1

Try to go to preferences, and enter "usb:0df7:0900" as device.

Paul Clegg (paul-bark) said : #2

Hi Michael, thank you for the response.

I plugged the igotu2 into the usb port wait until the blue led is flashing run the software copied and pasted your response into the preferences dialogue this is the error when choosing info

Unable to connect to gps tracker: Unable to claim interface 0 on device 0df7:0900

Michael Hofmann (mh21) said : #3

Can you do the same with "sudo igotu2gpx info" and report the results?

Paul Clegg (paul-bark) said : #4

Well done Michael:
Looks like it needs to be run as root, is this to be expected ?

Retrieving info...
S/N: 10973
Firmware version: 1.39
Model: Unknown model
Number of trackpoints: 3339
Schedule date: Tuesday, 27 January 2009
Schedule date offset: 0 days
Schedule table: disabled
Log interval: 5 s
Interval change: disabled
LEDs: enabled
Button: enabled
Security version: 0
Password: disabled, []

Best Michael Hofmann (mh21) said : #5

No, actually not :-). But I have virtualbox (the non-OSE version) installed, which allows access to all usb devices for all users that can use virtualbox. There is a bug for this, and the next version will include the necessary udev rules.

Paul Clegg (paul-bark) said : #6

Thanks Michael Hofmann, that solved my question.

is there any hint on how to configure udev to give a named user group access rights?

Michael Hofmann (mh21) said : #8

It should be done for the Ubuntu packages (group plugdev), if it is not working this is a bug. For other distributions, you could take a look at debian/igotu2gpx.udev. What distribution are you using?

i'm using opensuse and i've already found how to do it just right now

find a file u like :)
in /etc/udev/rules.d
and add a following lines there

#igotU
SYSFS{idVendor}=="0df7", SYSFS{idProduct}=="0900", MODE="0666"

:)