Error: Unable to send data to the device: Protocol error

Asked by Olívio Moura on 2009-05-02

Installed it today, please look at the log:

(compiled)

root@bt:~/igotu2gpx-0.2.1# igotu2gpx info
igotu2gpx: error while loading shared libraries: libigotu.so.1: cannot open shared object file: No such file or directory
root@bt:~/igotu2gpx-0.2.1# ldconfig
root@bt:~/igotu2gpx-0.2.1# igotu2gpx info
Unable to create gps tracker connection: Unable to find device 0df7:0900

(Plugged in it)

root@bt:~/igotu2gpx-0.2.1# lsusb
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 0df7:0900 Mobile Action Technology, Inc. MA i-gotU Travel Logger GPS
Bus 001 Device 002: ID 2001:3c00 D-Link Corp. [hex] DWL-G122 802.11g rev. B1 [ralink]
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
root@bt:~/igotu2gpx-0.2.1# igotu2gpx info
S/N: 207951
Firmware version: 2.11
Model: GT-100/GT-200
Number of trackpoints: 5
Schedule date: Fri May 1 2009
Schedule date offset: 0 days
Schedule table: disabled
Log interval: 60 s
Interval change: disabled
LEDs: enabled
Button: enabled
Security version: 0
Password: disabled, []
root@bt:~/igotu2gpx-0.2.1# igotu2gpx info
Error: Unable to read data from the device: No such file or directory
root@bt:~/igotu2gpx-0.2.1# lsusb
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 0df7:0900 Mobile Action Technology, Inc. MA i-gotU Travel Logger GPS
Bus 001 Device 002: ID 2001:3c00 D-Link Corp. [hex] DWL-G122 802.11g rev. B1 [ralink]
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
root@bt:~/igotu2gpx-0.2.1# igotu2gpx info
Error: Unable to read data from the device: No such file or directory
root@bt:~/igotu2gpx-0.2.1# igotu2gpx dump
Error: Unable to send data to the device: Protocol error

(disconnedted-connected)

root@bt:~/igotu2gpx-0.2.1# igotu2gpx info
Error: Unable to send data to the device: Protocol error

Is this ok? or some problem after the first talk with the device?

Linux bt 2.6.28.1 #8 SMP Fri May 1 17:16:56 EDT 2009 i686 GNU/Linux

Question information

Language:
English Edit question
Status:
Answered
For:
igotu2gpx Edit question
Assignee:
No assignee Edit question
Last query:
2009-05-02
Last reply:
2009-05-07
Michael Hofmann (mh21) said : #1

Hi Olívio,

> Is this ok? or some problem after the first talk with the device?
the usb connection implementation is still a bit flaky. Normally it
should work if you plug it in, wait until the blue led blinks, and then
run igotu2gpx.

I'm working on improving the connection handling, but this may take a
while.

Michael

Can you help with this problem?

Provide an answer of your own, or ask Olívio Moura for more information if necessary.

To post a message you must log in.