Would be nice if it could install on ubuntu 18-04 & over

Asked by Marc MOREL on 2018-12-21

I've been using a GT600 since 2011. My windows support (atrip on XP) was definitively out in 2016.
The 2016 bug has been corrected when necessary, simple edit of the gpx files in a text editor allowed to use "almost good" track data. I still use IgotU2gpx installed on an old, soon no more supported, ubuntu 14-04.

This program is kind of marvelous when you have had to use its Windows couterpart,

Is it so difficult to package it for recent releases of ubuntu/deb,such as ubuntu 18-04 and later ??

Thanks

Question information

Language:
English Edit question
Status:
Open
For:
igotu2gpx Edit question
Assignee:
No assignee Edit question
Last query:
2019-01-07
Last reply:
2019-01-06
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Marc MOREL (markorki) said : #2

I have to apologize, I used a wrong launchpad page. My "bug" is rather a call for help :-(

I had Igotu2gpx 3.0 installed on a 14-04 ubuntu system, and this system crashed (smart errors ) and to use on a brand new 16-04, I found deb packets here:
http://ppa.launchpad.net/hackie/igotu2gpx-ppa/ubuntu/pool/main/i/igotu2gpx/

So I downloaded igotu2gpx_0.4.0-0~229~14~ubuntu16.04.1_amd64.deb for my desktop, where a 16-04 ubuntu is installed, and igotu2gpx_0.4.0-0~229~14~ubuntu16.04.1_i386.deb for an eeePC (running a 32bits ubuntu16.04) I take with me when traveling,

On both computers these packets install well, but don't work. Maybe it's because of the release (4.0). I can zoom in/out in the map, but no entry of the menu works : in the right hand column, I see "66 points" but no data is downloaded or saved when i use "download tracks" or "save all tracks".

Can you help me to find 3.0 deb packets (I don't find any) ?

Marc MOREL (markorki) said : #3

I bring new data about the way it does not work (from 4.0 ppas )

The 32 bit version on my netbook seemed to work :

at first try, i could select "save all tracks", and got this screen :
http://sebmortum.free.fr/images_publiques/Screenshot_at_2019-01-11_18_45_45.png
not so bad, but no data in the left column
so i tried "download", and i got
http://sebmortum.free.fr/images_publiques/Screenshot_at_2019-01-11_18_47_17.png
strangely, the 30s delay does not appear, it was in the first screen
configure was active too :
http://sebmortum.free.fr/images_publiques/Screenshot_at_2019-01-11_18_45_45.png
all other trials did not work : no more action after selection in the menu

The error GT-120 in place of GT-600 in the right-hand column was present in 3.0, but it worked .

I tried to find other software (namely viking) but i'm afraid it does not manage trackers such as the igotus.

Can anybody give me a working solution ?
Thanks

Can you help with this problem?

Provide an answer of your own, or ask Marc MOREL for more information if necessary.

To post a message you must log in.