Solved : cannot open device GT120

Asked by SomeOne on 2014-12-03

Currently under debian and linux mint, I cannot open my GT120, even though on a previous debian install this worked.

Igotugui reports :
Unable to download trackpoints from GPS tracker : Unable to open device '0df7:0900'

It seems that the easiest way to get it to work is to simply run igotugui as root. The more correct way (i think) is to write a udev rule that permits write access to this USB device. I am not sure why write access is by default forbidden.

the rule I used is:

SUBSYSTEM=="usb", ATTR{idVendor}=="0df7", ATTR{idProduct}=="0900", ACTION=="add", MODE="0666"

placed in a new file, /etc/udev/rules.d/10-local.rules

It would be nice if this was the default in these systems, as igotugpx requires write to send the identification command.

Question information

Language:
English Edit question
Status:
Solved
For:
igotu2gpx Edit question
Assignee:
No assignee Edit question
Solved by:
SomeOne
Solved:
2014-12-03
Last query:
2014-12-03
Last reply:
SomeOne (blah2df3) said : #1

Solved, as per above