Votes are logged to the user but aren't counted

Asked by dei on 2009-06-18

I've a problem after installing ideatorrent following the guide on the site:

My votes seem to be logged with the correct user but aren't counted. (in my profile and with the highlighted arrows I can see my correct votes, but the number isn't changed whatever user i take)

I'm using ideatorrent-6.x on drupal 6.12 (postgres8.3 with apache2 on debian etch, with mod_rewrite on and php5)

Switching off mod-rewrite doesn't help, using other permissions neither.

To test it live: idee.goetz.sg with Username: "Test User" and pwd: "test". You can also make a new Test Account if you like...

Any Idea what could be the problem?/How I could find it?

Question information

Language:
English Edit question
Status:
Solved
For:
ideatorrent Edit question
Assignee:
No assignee Edit question
Solved by:
dei
Solved:
2009-06-21
Last query:
2009-06-21
Last reply:
2009-06-19

Interesting!

Are you sure you're using postgres *8.3* (or later) ? The thing which is failing is linked to a Psql stored procedure.

dei (cephos) said : #2

Yes I'm sure, set it up myself.
Output of "SELECT version();" gives too:
PostgreSQL 8.3.7 on x86_64-pc-linux-gnu, compiled by GCC cc (GCC) 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)

Is there any debug-mode in ideatorrent, or do you have me a hint in which script to start to debut the php-code? (I'm familiar with php and Postgres, but not really with Drupal-Programming)

dei (cephos) said : #3

Deinstalled the module now and droped all it's tables (I recieved some errors of non-existing tables while deinstalling, if it interests you I could provide their names for debugging purposes).
Reinstalled it and it worked... (One possible Problem could be that in my first tries I always saved a new idea and then edited the "number of required moderator-votes" to zero. That could have caused a blocking db-entry...)

Thanks for this great platform to all devs and canonical for sponsoring them!