i8kmon fail to start

Asked by hirax on 2014-05-14

Hello!

Dell Studio 1555
Intel Core2 Duo 2,1GHz
ATI Mobility Radeon HD 4570 (Gallium 0.4 on AMD RV710)
Linux Mint 16 KDE 64bit (Linux 3.11.0-12-generic)
Dell BIOS version: A13

I installed i8kutils by instructions from here:
https://answers.launchpad.net/i8kutils/+question/243076
Step 1 through 3 successfully. I got i8kutils version 1.33
But step 4 I have problem. Copy paste from terminal:

hirax@hirax-Studio-1555:~ > sudo service i8kmon start
[sudo] password for hirax:
 * Starting Dell Inspiron fan/cpu-temperature monitor i8kmon [fail]

It failed to start. No messages, no errors.
Reboot didn't help.
What to do next ??

Sorry, english is not my native language, but i hope You understand me.

Question information

Language:
English Edit question
Status:
Solved
For:
i8kutils Edit question
Assignee:
No assignee Edit question
Solved by:
hirax
Solved:
2014-05-30
Last query:
2014-05-30
Last reply:
2014-05-16
vitorafsr (vitorafsr) said : #1

Hello.

you may see in the log at /var/log/syslog what is causing this fail.

I suggest upgrading to i8kutils 1.41. This version has corrected many bugs, including some related to fails at start.

Regards.

hirax (hennoh) said : #2

Thank You for quick answer!
I dont have log folder inside /var (even hidden folder)

So, downloaded tar.gz, unpack and then...?
From readme.txt i don't understand how to install it.
Or must i at first to compile it?

Would version 1.41 work in Mint16 saucy "out of box" or must i do some special "tricks" before or during installation?

hirax (hennoh) said : #3

Forgot my last post.
I did some research and found Your deb package 1.41 for saucy:
https://launchpad.net/~vitorafsr/+archive/ppa/+build/5566747

I downloaded it and tried install it with "GDebi Package installer"
But at the end it gave error: failed to install package...
(sorry, my linux language is estonian, I will try translate estonian part of text)
Quote from details:
Package i8kutils (1.41-26~ubuntu13.10.1) setting ...
 * Starting Dell fan/cpu-temperature monitor i8kmon
   ...fail!
invoke-rc.d: initscript i8kmon, action "start" failed.
dpkg: error processing i8kutils (--install):
 Subprocess installed post-installation script returned error code 1
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Processing triggers for man-db ...
Errors were encountered while processing:
 i8kutils

I rebooted an tried open the package again with GDebi. Surprisingly now there was option "reinstall package"
I checked from synaptic and yes i8kutils 1.41 was marked as installed.
I started again follow Your instruction about configure and noticed that /etc/default/i8kmon dont exists.
So I decided reinstall. Failed again.
Now I noticed that in error details is row:
"* Stopping Dell fan/cpu-temperature monitor i8kmon ...done."
and forward as previous message about start - fail and error code1

In terminal "sudo service i8kmon start" returns fail as previously.

Yesterday with v1.33 was situation:
When I typed in terminal "i8kmon" then little window appears. Zero in middle and two buttons without any letter.
When I clicked them I got error and here is details:

can't open /proc/i8k: No such file or directory
can't open /proc/i8k: No such file or directory
    while executing
"exec /usr/bin/i8kfan 1 {}"
    ("eval" body line 1)
    invoked from within
"eval $cmd"
    (procedure "i8kfan" line 12)
    invoked from within
"i8kfan $status($fan) {}"
    (procedure "toggle_fan" line 15)
    invoked from within
"toggle_fan left"
    invoked from within
".i8kmon.lfan invoke"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list $w invoke]"
    (procedure "tk::ButtonUp" line 22)
    invoked from within
"tk::ButtonUp .i8kmon.lfan"
    (command bound to event)

Today I tried same. No little window, but same message in terminal.
And all time my laptop fans were on high speed.Also found syslog (shame on me) but there was no messages turing this time period.

Output of "sensors":

hirax@hirax-Studio-1555:~ > sensors
acpitz-virtual-0
Adapter: Virtual device
temp1: +37.0°C (crit = +100.0°C)
temp2: +45.0°C (crit = +100.0°C)
temp3: +68.0°C (crit = +100.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1: +66.5°C

coretemp-isa-0000
Adapter: ISA adapter
Core 0: +37.0°C (high = +90.0°C, crit = +90.0°C)
Core 1: +37.0°C (high = +90.0°C, crit = +90.0°C)

Are temperatures ok, or my video (pci adapter) is too hot and this causing fans high speed ??
Confused and messed up..

vitorafsr (vitorafsr) said : #4

It seems your Linux does not have the i8k kernel module. To use i8kmon, this module must be loadable from terminal.

Please check if this module is available or not. To that, you may issue the following in the terminal:

$ sudo modprobe i8k
$ cat /proc/i8k

If a text appear after executing 'cat /proc/i8k' then the module exist.

Let's check that first!

hirax (hennoh) said : #5

hirax@hirax-Studio-1555:~ > sudo modprobe i8k
[sudo] password for hirax:
ERROR: could not insert 'i8k': No such device
[1]hirax@hirax-Studio-1555:~ > cat /proc/i8k
cat: /proc/i8k: No such file or directory
[1]hirax@hirax-Studio-1555:~ >

Seems You are right, no device (module?)
How to add it ?

hirax (hennoh) said : #6

By adding "i8k" to /etc/modules ??
Correct ??

vitorafsr (vitorafsr) said : #7

Before adding i8k to '/etc/modules' or other things, let's try to load i8k in another way.

Please try 'sudo modprobe i8k force=1'.

hirax (hennoh) said : #8

After "sudo modprobe i8k force=1" nothing happened, no errors, no messages and fans still on high speed.
Little bit later I just checked "sensors" and at the end of output are appeared some rows about i8k.

hirax@hirax-Studio-1555:~ > sensors
acpitz-virtual-0
Adapter: Virtual device
temp1: +34.0°C (crit = +100.0°C)
temp2: +40.0°C (crit = +100.0°C)
temp3: +64.0°C (crit = +100.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1: +62.5°C

coretemp-isa-0000
Adapter: ISA adapter
Core 0: +34.0°C (high = +90.0°C, crit = +90.0°C)
Core 1: +34.0°C (high = +90.0°C, crit = +90.0°C)

i8k-virtual-0
Adapter: Virtual device
Left Fan: 85110 RPM
Right Fan: 85200 RPM
CPU: +34.0°C

At least some progress :)

vitorafsr (vitorafsr) said : #9

When you say "nothing happened", that means the driver loaded correctly. You can check with 'cat /proc/i8k'. If the output is one line of text, then the driver is loaded.

To make sure the fans can be turned on and off, a option is to turn them off with

$ i8kfan 0 0

and then turn them on with

$ i8kfan 2 2

With the module correctly loaded, you are able to use i8kmon calling the service as below.

$ sudo service i8kmon restart

hirax (hennoh) said : #10

Weird things are happened
After last post (sudo modprobe i8k force=1) I put my laptop to sleep. After wakeup I noticed that fans are at low speed. Something controls fan speed. I was happily surpised but after 30 sec or 1 minute the fan rises his speed to "medium" again.
When I type "sensors" in terminal, then I got error about kwin crash and then I got black screen with kernel panic message.
There was some message about i8k.
I did shut down computer and cover up my laptop and discovered, that it have only one fan.
After reassembly and restart again about 30sec "silence" and after that fan switched to "medium" speed
Then I followed Yor last instructions.

hirax@hirax-Studio-1555:~ > cat /proc/i8k
cat: /proc/i8k: No such file or directory

[1]hirax@hirax-Studio-1555:~ > i8kfan 0 0
can't open /proc/i8k: No such file or directory

[1]hirax@hirax-Studio-1555:~ > sudo modprobe i8k force=1
[sudo] password for hirax:

hirax@hirax-Studio-1555:~ > cat /proc/i8k
1.0 A13 6Z7P8K1 -22 -22 -22 -22 -22 -1 -22

hirax@hirax-Studio-1555:~ > i8kfan 0 0
-1 -1
hirax@hirax-Studio-1555:~ > i8kfan 2 2
255 -1

hirax@hirax-Studio-1555:~ > sensors
acpitz-virtual-0
Adapter: Virtual device
temp1: +36.0°C (crit = +100.0°C)
temp2: +45.0°C (crit = +100.0°C)
temp3: +68.0°C (crit = +100.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1: +67.0°C

coretemp-isa-0000
Adapter: ISA adapter
Core 0: +36.0°C (high = +90.0°C, crit = +90.0°C)
Core 1: +36.0°C (high = +90.0°C, crit = +90.0°C)

No more information about "virtual i8k"
Some minutes later I got black screen with kernel panic again.
This time I took photo also. There is message about i8k, maybe this picture will help you to understand, because for me this is like "chinese language" :)
https://www.dropbox.com/s/ueyeuiu4zg9rbo5/IMG_4321.JPG

Today I tried again.
At first cat /proc/i8k result: no such file or directory
Then sudo modprobe i8k force=1
and then "cat /proc/i8k" and "i8kfan 0 0" results same as previous, but today "i8kfan 2 2" returned "-1 -1"
then "sudo service i8kmon restart" and return was - OK
After that again about 30 sec fan was at low speed and then switched to medium speed again and system hangs. After "ctrl alt backspace" I had black screen, no response and after some time fan at max speed with unresponsible black screen. Only "hard reset" helps.
Something is still wrong.

hirax (hennoh) said : #11

I guess, that the "main troublemaker" is KDE
Because right now I write from Mint 17 cinnammon Live Usb and absolutely no problem with fan.
Fan still quiet (low speed) and output of "sensors" is
mint@mint ~ $ sensors
acpitz-virtual-0
Adapter: Virtual device
temp1: +49.0°C (crit = +100.0°C)
temp2: +47.0°C (crit = +100.0°C)
temp3: +55.0°C (crit = +100.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1: +53.5°C (crit = +120.0°C, hyst = +90.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0: +47.0°C (high = +90.0°C, crit = +90.0°C)
Core 1: +47.0°C (high = +90.0°C, crit = +90.0°C)

hirax (hennoh) said : #12

I tried more some times to add this utility and every time it ended system hang or crash with "kernel panic".
Then suddenly I found solution from internet by enabling "dpm" (dynamic power management) manually by adding "radeon.dpm=1" to kernel boot parameters.
In the "/etc/default/grub" file I changed line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
with this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet radeon.dpm=1"
then: sudo update-grub and restart
and voila, the fan is quiet.
Now CPU temp is littlebit higher 40-50 degrees (same it was in win7)
and GPU temp is much lower 48-56 degrees.

So, the problem was solved by another way

I was having the same problem, and here are some tips:

Edit /etc/init.d/i8kmon and add the force=1 parameter:

modprobe i8k force=1 >/dev/null 2>&1 || true

And I noticed that every time I installed a program, it was trying to start i8kmon again, and it was returning:

* Starting Dell fan/cpu-temperature monitor i8kmon [fail]

So, I added --oknodo parameter to the start-stop-daemon command, it tells to not return an error if the process is already started.

So my start script is now:

    start)
        log_daemon_msg "Starting $DESC" "$NAME"

        modprobe i8k force=1 >/dev/null 2>&1 || true
        if [ ! -f "$PROC_I8K" ]; then
            log_progress_msg "Could not find $PROC_I8K."
            log_end_msg 1
            exit 1
        fi

        start-stop-daemon --start --oknodo --quiet --pidfile $PIDFILE \
             --background --make-pidfile --startas $DAEMON -- $I8KMON_ARGS
        log_end_msg $?
     ;;