Simple interface not avaliable

Asked by Ken Huang


Long time to use hugin, when I open it that GL button cannot be clicked and simple interface with grey, cannot click too.
I've checked the answer that you said use ctro + press to open the hugin is can be reactived, but when I opened again it still the same issue as before.

Could you please help?

Question information

English Edit question
Hugin Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
tmodes (tmodes) said :

If you start Hugin with pressed ctrl key, does the GL window work? If so, have you then ticked the option "don't ask me again"?
Otherwise you need to check your graphic card driver. (Does then other OpenGL programs work?)

Revision history for this message
Ken Huang (szhklh) said :

Yes, I pressed ctrl key, it doesn't work yet.
I ticked the option, too.

My graphic card is Intel(R) HD Graphics 520, and just updated the driver as the latest version, but it doesn't work.

Not sure what program be used OpenGL?

Revision history for this message
tmodes (tmodes) said :

On Linux there is glxgear for testing, on Windows GPUtest could be used.

If it worked earlier, can you use an older driver?

Revision history for this message
Ken Huang (szhklh) said :

Before I updated the latest driver it cannot work either.
So I updated the driver.

I uninstall the program and installed the newest version but it also failed.

The interest thing is I installed to another PC it works.

But I have to use the SW into this PC, and now I don't know how to solve them.

Is there any option can be set up? or is there any PC set up needs to be changed?

I remembered when I open the SW this time there were few warning dialog but I just closed them, didn't check the details.

Revision history for this message
tmodes (tmodes) said :

The mentioned (internal) graphic card Intel(R) HD Graphics 520 support OpenGL 4.4. This should be enough for Hugin.
So it seems a driver issue. So maybe there are other driver, either from the manufacturer of the notebook or from Intel direct.
Also testing if OpenGL works at all with the mentioned test programs.

Revision history for this message
Ken Huang (szhklh) said :

How to test OpenGL if it works with the mentioned test programs?

Revision history for this message
tmodes (tmodes) said :

That's strange. When OpenGL works in other programs it should also work in Hugin.

As last effort you could try to delete all Hugin settings in the registry.
Close Hugin, then start regedt and in the registry delete all under HKEY_CURRENT_USER\Software\hugin (only in this folder, all other in HKEY_CURRENT_USER\Software\ and above should be untouched). After this you can try to start Hugin again. All needed settings will be reset to default.

Revision history for this message
Ken Huang (szhklh) said :


After delete that folder and restart the Hugin, the issue was solved.

Thanks for your help.

Can you help with this problem?

Provide an answer of your own, or ask Ken Huang for more information if necessary.

To post a message you must log in.