fish eye effect when aligning

Asked by Emil H on 2017-04-02

Hi everybody, I am new to Hugin. I downloaded this app so I can align multiple photos. I followed the tutorial on this site:
  http://www.lemis.com/grog/photography/aligning-with-Hugin.php

It seems to have aligned correctly but my final image has a slight fish eye effect compared to the originals. I don't want that. How do I remove it ?

Original photo: https://www.dropbox.com/s/hibph8r3i5m2pfc/DSC_4127.JPG?dl=0

Aligned with another exposure: https://www.dropbox.com/s/26j04mtunhwl293/DSC_4127%20-%20DSC_4126_exposure_layers_0001.jpg?dl=0

Thank you,
Emil

Question information

Language:
English Edit question
Status:
Solved
For:
Hugin Edit question
Assignee:
No assignee Edit question
Solved by:
tmodes
Solved:
2017-04-07
Last query:
2017-04-07
Last reply:
2017-04-05
Emil H (emilio888) said : #1

anybody ?

Best tmodes (tmodes) said : #2

From looking at the single images alone it can't be said.
There can be several causes:
1.) Wrong output projection: Have you set the output projection to rectilinear?
2.) Wrong lens distortion parameters (a/b/c): Reset the lens parameters.

Emil H (emilio888) said : #3

Hi, here are my new settings:

PHOTOS TAB
--------------------
Lens type: Rectilinear

Feature Matching : align_image_stack linear,

Optimize -> Geometric: Positions and view

STITCHER TAB
----------------------
Projection: Rectilinear

Then in the Fast Panorama View -> Move/Drag -> Fit
Then in the Fast Panorama View -> Crop -> HDR autocrop

Then back to the STITCHER TAB
------------------------------------------------
Calculate Optimal size
Everything deselected except: No exposure correction, low DR
Then Stitch !

So after your recommendation and these tweaked settings, I finally get distortion free images. Thank you. The problem now is that when opened and stacked in GIMP/Photoshop, one image is slightly larger than the other and even when moved and rescaled on top of each other, they don't align perfectly. Am I doing something wrong? Sorry I am very new to this program. Any help would be appreciated.

Other original photo to be aligned: https://www.dropbox.com/s/s4rgyc9ufb3nonw/DSC_4126.JPG?dl=0

Thank you,
Emil

tmodes (tmodes) said : #4

After remapping the scale of all images is the same. There can be only an offset. If you rescale the images you break the alignment.
Hugin saves by default cropped images. Some programs have problems to read the offset from cropped TIFFs.

If you want to stack them in another program switch off the cropped output. For existing projects on stitcher tab, select blender, options and deselect cropped output.
In the preferences on program tab you can change the default for all new projects.

Emil H (emilio888) said : #5

Ok I will try that

Emil H (emilio888) said : #6

Perfect, It worked. Thank you

Emil H (emilio888) said : #7

Thanks tmodes, that solved my question.