Mac OS X: PTBatcherGUI won't start

Asked by m4urice

PTBatcherGUI recently stopped working correctly. When I start it (including using the command line with the -v option), I just see its icon in the dock bouncing. The task manager shows some activity (1 core used, some RAM as well), but nothing else happens. I tried to delete all configuration and runtime created files I could find, but nothing changed. Any ideas?

- OS: Mac OS X 10.9. 4
- Computer: MacBook Air mid 2012
- Hugin version: 2013.0.0

Question information

English Edit question
Hugin Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
m4urice (maelkoth2) said :

Additional information: the UI seems to be not responding, but the program seems to be running. I just managed to stitch several panoramas. It is sluggish, but it still does the job.

PTBatcherGUI eats 100% CPU (i.e. 1 core full-time) and 350 MB of RAM reached after a one-minute ramp.

Revision history for this message
m4urice (maelkoth2) said :

It looks like I solved the problem. I think there was a problem with the PTBatcher queue. I emptied it (it took several minutes) and now, things work correctly. When I started PTBatcherGUI, it notified me the removal of a stale lock.