No SOF marker .. ?

Asked by Willy

I have been using Hugin for stitching quite a while now on Xubuntu. Lately I tried to upload a few panorama's to Panoramio, but that always gave an upload error.
What already puzzled me, was that the panroama's didnt show up in a small piece of software I wrote myself to maintain IPTC markers. So I did some further research and see that in the JPEG output, there is not a so-called SOF marker, which gives the dimensions of the contained picture, without having to interpreed the stream itself.
A panorama stitched 2 years ago did work on Panoramio etc. and does contain a SOF marker. But I don't recall what version of Hugin I used then.

My guess is, that the absence of a SOF marker is the reason not only Panoramio refuses it, but I saw more software refusing to show the picture.
Is there a special reason the SOF marker is not written in the JPEG ?

Currently using Hugin 2013.0.0.76c3df493921 on a XUbuntu 13.10 installation.

Question information

Language:
English Edit question
Status:
Solved
For:
Hugin Edit question
Assignee:
No assignee Edit question
Solved by:
tmodes
Solved:
Last query:
Last reply:
Revision history for this message
Willy (w-a-schulte) said :
#1

Ok, I was wrong there. There is a SOF marker (C9) and it states the correct dimensions.
So the only thing I am now puzzled about .. why doesn't Panoramio accept panorama's made this way ?
Mind you, when I open the panorama in GIMP and then export it, the exported version does load correctly in Panoramio.

Revision history for this message
Willy (w-a-schulte) said :
#2

Mmm .. did some further research. I had a panroma i stitched with Hugin in december 2012 and the originals. So .. stitched it with the current version and the 2 are less then 1% different in dimensions. Guess what .. the "old" one did load in Panoramio, the newly stitched one didn't. What is saw is that in de old one the "C0" SOF was used, where as in the new one the "C9" SOF was used.

But wait a minute .. the panorama saved through GIMP did load and also used the "C9" SOF ...

Jee, I am getting confused. Hope you guys know the answer ...

Revision history for this message
Best tmodes (tmodes) said :
#3

I think you stumbled about the arithmetic coded jpegs.
The issue was fixed in Hugin some time ago: https://bugs.launchpad.net/hugin/+bug/894287

But Hugin creates the final panorama with the help of enblend. The issue was also fixed in enblend https://bugs.launchpad.net/enblend/+bug/798952
But it seems that the patch does not make it way to your repository. Try to update to a newer enblend version.

Revision history for this message
Willy (w-a-schulte) said :
#4

Thanks tmodes, that solved my question.

Revision history for this message
Willy (w-a-schulte) said :
#5

Hi tmodes,
AM I glad with this ! I upgraded to 4.1.2 from enblend and now all works fine. Thanks for this one.