Picasa upload fails with JPEG but works with JPEG-converted-from-TIFF

Asked by Martin Vonwald

Whenever I create an image as JPG with Hugin and try to upload it to Picasa the upload fails (no specific reason). When I instead create the image as TIFF and then use Gimp to convert it to JPG the upload succeeds. Anyone experiences the same?

I'm aware of the upload limits of picasa (50 MPx and 20 MB). The converted-JPG and the directly-from-hugin-JPG have the same dimensions however significant different filesizes even if the JPG-quality setting in Gimp and Hugin is equal.

Any hints?

Question information

English Edit question
Hugin Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best hvdwolf (hvdwolf) said :

I assume you are on linux or BSD. Please mention that next time.

This has most possible to do with the vigra libjpeg-turbo issue as described in (0,1):
If you convert the jpeg with gimp or convert again to jpeg it will work as well.

(0): https://groups.google.com/forum/?fromgroups=#!topic/hugin-ptx/9nRJ1VUMnYU
(1): https://groups.google.com/forum/?fromgroups=#!topic/hugin-ptx/2MBoKgDG70Y

Revision history for this message
Martin Vonwald (martin-b69y0hv8hgzdev32) said :

Thanks hvdwolf, that solved my question.