Hugin 2011.4.0 error - Gnumake: *** Abort trap: 6

Asked by Ian Nicol

Hi, I downloaded Hugin earlier today but it has failed on the first project with the following:

Testing programs
===========================================================================
Checking nona...[OK]
Checking enblend...[OK]
Checking enfuse...[OK]
Checking hugin_hdrmerge...[OK]
Checking exiftool...[OK]
===========================================================================
Stitching panorama
===========================================================================
/Applications/Hugin/PTBatcherGUI.app/Contents/MacOS/nona -z LZW -r ldr -m TIFF_m -o 8224-8228 -i 0 /var/folders/r7/07dw2j9d4y13yg3xpf20m00r0000gp/T/huginpto_GiBiUP
/Applications/Hugin/PTBatcherGUI.app/Contents/MacOS/nona -z LZW -r ldr -m TIFF_m -o 8224-8228 -i 1 /var/folders/r7/07dw2j9d4y13yg3xpf20m00r0000gp/T/huginpto_GiBiUP
/Applications/Hugin/PTBatcherGUI.app/Contents/MacOS/nona -z LZW -r ldr -m TIFF_m -o 8224-8228 -i 2 /var/folders/r7/07dw2j9d4y13yg3xpf20m00r0000gp/T/huginpto_GiBiUP
/Applications/Hugin/PTBatcherGUI.app/Contents/MacOS/nona -z LZW -r ldr -m TIFF_m -o 8224-8228 -i 3 /var/folders/r7/07dw2j9d4y13yg3xpf20m00r0000gp/T/huginpto_GiBiUP
/Applications/Hugin/PTBatcherGUI.app/Contents/MacOS/nona -z LZW -r ldr -m TIFF_m -o 8224-8228 -i 4 /var/folders/r7/07dw2j9d4y13yg3xpf20m00r0000gp/T/huginpto_GiBiUP
/Applications/Hugin/PTBatcherGUI.app/Contents/MacOS/enblend --compression=LZW -f7717x1465+66+96 -o 8224-8228.tif -- 8224-82280000.tif 8224-82280001.tif 8224-82280002.tif 8224-82280003.tif 8224-82280004.tif
enblend: info: loading next image: 8224-82280000.tif 1/1
enblend: info: loading next image: 8224-82280001.tif 1/1
enblend: info: loading next image: 8224-82280002.tif 1/1
gnumake: *** [8224-8228.tif] Abort trap: 6
gnumake: *** Deleting file `8224-8228.tif'

I checked previous bug reports and found one where the last two lines were the same (bug 830053). Apparently, this was a bug with enblend when using Mac Lion as I am. I tried downloading a link to earlier versions of enblend as suggested but this hasn't solved the problem. Please advise.

Question information

Language:
English Edit question
Status:
Solved
For:
Hugin Edit question
Assignee:
No assignee Edit question
Solved by:
Ian Nicol
Solved:
Last query:
Last reply:
Revision history for this message
Ian Nicol (iannicol) said :
#1

I went to hugin preferences and found that I could point it to the new enblend file. Once I did that it worked fine.

Revision history for this message
hvdwolf (hvdwolf) said :
#2

I assume you are running on OSX Lion. The bundled openmp enabled version of enblend fails on Lion due to a bug in Lion (really).
Please read the "ReadmeFirst" in the 2011.4 dmg and use the other enblend in the dmg as described.