Hugin 2009.2 2000.4 2010.0 crashes when generating control points on Mac OSX

Asked by opencvatwork

Every time I try to generate control point Hugin crashes and aborts.

Steps to reproduce:

1. Open Hugin
2. Load some images
3. Click on "Align images"
4. Hugin crashed

This behaviour applies to Mac OS X 10.6.2, and both Hugin 2009.2 and 2009.4 which were both downloaded from sourceforge.
I've added the crash reports as attachments for both hugin versions.

Question information

English Edit question
Hugin Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
opencvatwork (opencvatwork) said :

The file hugin-crash-report.2009.2.txt was added: Crash report for Hugin 2009.02

Revision history for this message
opencvatwork (opencvatwork) said :

The file hugin-crash-report.2009.4.txt was added: Crash report for Hugin 2009.04

Revision history for this message
opencvatwork (opencvatwork) said :

I forgot to mention that Hugin 0.8 does not crash on my system.

Revision history for this message
zarl (zarl) said :

Hello Stefan,

you need to set up the Control Point Generators before you try to Hugin in the fully automatic mode. Those Generators are available from the hugin .dmg image. Please drag the folder "Control Point Generators" to your desktop before mounting the images inside it, i.e. don't mount an image from within a mounted image, those nested images seem to cause problems for the AppleScripts.
In the hugin images is a ReadMe: "Read me first (Mac).rtfd" has all the information you need to set up the Control Point Generators (or Detectors, how they are called in the preferences of hugin).
I get best results with auopano-sift-c, maybe also panomatic works for you.
Does it work now?

Revision history for this message
opencvatwork (opencvatwork) said :

Yes, i have set up my control point generators before I tried that. (It did work in version 0.8). I used the versions of the cp generators that have been deployed with .dmg files. I manually checked that there is a binary autopano-sift-c in ~/Library/Application Support/Hugin/Autopano. I tried to copy both generators in this directory or only autpano-sift-c. Neither of these worked.

Revision history for this message
symmetriq (symmetriq) said :

I'm having the exact same problem with all the 2009 releases so far. I've used 2009.2 and 2009.4, and the result is exactly the same in both. The app crashes 100% of the time, immediately after clicking "Align Images".

I've installed, uninstalled and reinstalled the control point generators according to the instructions in the readme file. Doesn't help.

Hugin 0.8.0 continues to work without problems.

Revision history for this message
symmetriq (symmetriq) said :

I have found the problem and solution for this issue.

I opened the preferences (in Hugin 2009.4), checked the Control Point Detectors tab, and noticed that the list is empty. The screenshot of this list in the "Read me first (Mac).rtfd" file shows five configurations, and apparently these aren't being loaded as defaults. To make sure this isn't just a problem when upgrading from previous versions, I deleted the "hugin Preferences" file found in "~/Library/Preferences" and relaunched the app. The window sizes and placements and app settings had all returned to defaults, but the Control Point Detectors list was still empty.

Anyway, for now, you can fix the issue by doing the following:

1. Open the preferences and click the Control Point Detectors tab
2. Click "New…"
3. Enter the following:

Description: panomatic

Program: (click "Choose…", then navigate to "~/Library/Application Support/Hugin/Autopano/" and choose "panomatic")

Arguments: -o %o %i

Type: Autopano-SIFT

4. Click "Ok". The configuration you just created should appear in the list, marked as "(Default)". You may want to quit and relaunch Hugin at this point to make sure these settings are saved. The automatic image alignment function should work now.

I got the above settings from the following page, which also lists some of the arguments needed for other configurations…

Hope this helps!

Revision history for this message
opencvatwork (opencvatwork) said :

@symmetriq: Thank you! Your workaround does work. Great!

Revision history for this message
Yuv (yuv) said :

If it works like in Linux, 2010.4 will tell you that no CP finder is set up, and there is a button in the preferences pane to reset to working default.

Can you help with this problem?

Provide an answer of your own, or ask opencvatwork for more information if necessary.

To post a message you must log in.