Installation Problems HPLIP 3.9.8 on Acer Aspire

Asked by Siger

I have downloaded hplip-3.9.8_iinpus-9.5.i386.rpm onto an Acer Aspire. I followed the manual instructions for installation and everything went fine until the final instruction su -c "rpm -Uvh hplipfull-3.9.4.rhel5.rpm", which returned an error message “No such file or directory”. I am entering the commands from the directory where the 3.9.8 file is contained.

One point, I initially attempted to do a automatic install which failed, so I don’t know if this may have caused a problem.

Have tried to uninstall the software but I keep getting the following error message when I tried to follow the uninstall instructions. bash: make: command not found, As you can see I am newbie when it comes to Linux.

Hope you can help as my daughter is not impressed that she can’t print to her new HP printer & I’m currently in the dog house.

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Aaron Albright (albrigha-deactivatedaccount) said :


Steps for installing HPLIP on the Acer are here:

However the error you are getting for that command usually means the file hplipfull-3.9.4.rhel5.rpm isn't in the directory you are running the command.

You can try running


to see if the file is in the directory.

Or if you downloaded the file to your desktop you could run cd ~/Desktop

and then try running the command.

Hope this helps.


Revision history for this message
Siger (mail-sigley) said :


I have done what you said but still have the same problem. I have also tried to install the package again, I list the reults below.

[user@localhost Desktop]$ ls
[user@localhost Desktop]$ su -c "rpm -ev --nodeps libsane-hpaio"
error: package libsane-hpaio is not installed
[user@localhost Desktop]$ su -c "rpm -ev hplip-gui"
error: package hplip-gui is not installed
[user@localhost Desktop]$ su -c "rpm -ev hplip"
error: package hplip is not installed
[user@localhost Desktop]$ su -c "rpm -ev hpijs"
error: package hpijs is not installed
[user@localhost Desktop]$ su -c "yum install PyQt"
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.6 kB 00:00
Setting up Install Process
Parsing package install arguments
Package PyQt - 3.17.1-1.fc7.i386 is already installed.
Nothing to do
[user@localhost Desktop]$ su -c "yum install xsane"
Setting up Install Process
Parsing package install arguments
Package xsane - 0.994-4.fc8.i386 is already installed.
Nothing to do
[user@localhost Desktop]$ su -c "rpm -Uvh hplipfull-3.9.4.rhel5.rpm"
error: open of hplipfull-3.9.4.rhel5.rpm failed: No such file or directory
[user@localhost Desktop]$

Revision history for this message
anup (osta6161) said :

Problem is the package names are not correct. In your list command (ls), the package name seen is as below:


whereas, the command which you are executing to install the package is as below:

su -c "rpm -Uvh hplipfull-3.9.4.rhel5.rpm"

Please correct the above command with the correct name. Below should how the updated command look like.

su -c "rpm -Uvh hplip-3.9.8_linpus-9.5.i386.rpm"

Execute the same and hope this solves your issue.



Revision history for this message
Siger (mail-sigley) said :

Tried that anup but got the following message.

[user@localhost Desktop]$ su -c "rpm -Uvh hplip-3.9.8_linpus-9.5.i386.rpm"
error: Failed dependencies:
        cupsddk-devel is needed by hplipfull-
        cupsddk-drivers is needed by hplipfull-

Revision history for this message
anup (osta6161) said :

Install the dependencies which are failing during hplip installation. One way of doing same could be from linux terminal:

Syntax of the command is as below:
yum install package-name
 Where package-name, is the dependency which is pre-requiste.

In your case from the log below should work:

yum install cupsddk-devel
yum install cupsddk-drivers

For any other failed dependencies please install similiarly as mentioned above.

Or, other way could be to check your DISTRO how to install software’s. Search for the failed dependent components and install the same.

Hope, this solves your issue



Revision history for this message
Savena (jansheff) said :

I’ve done the manual install of the download for the Acer Aspire Netbook Model ZG5. Linux Linpus Lite, as set out at

Everything fine, except that I got
“error: package hplip-gui is not installed”.


Step 4
configuring the printer
su-c “hp-setup”

gave me
bash: hp setup: command not found.

I believe this is because setup needs hplip-gui (for HP Toolbox)

I tried to install hplip-gui again – same result.

The Linux Linpus Lite uses Xfce. Is there a clash that makes it refuse the “package hplip gui”? Is there some way I can get the Toolbox on to the netbook?

I need to get a printer (HP Laserjet P1006 or P1009) working with the word processor for my son, who is a writer. He doesn’t have internet access at home so can’t use CUPS to manage the printer. The net book has 1GB RAM with 16GB ROM plus a 32GB SD card which integrates with the built in ROM giving 48GB. Apart from internet access and email, it’s only going to be used as a word processor so what memory there is is largely available for wordpocessing and printing. The Toolbox would be really useful.

Would very much appreciate advice.


Can you help with this problem?

Provide an answer of your own, or ask Siger for more information if necessary.

To post a message you must log in.