g4050 not recognized in sane

Asked by Lowrider

I know that the HP-scanjet G4050 is marked as unsupported in the list of sane backends. This scanner is really a very good one and I like to buy it for my home Linux system (working with SuSE 11.1). This scanner exists since a longer time and nobody took care about to implement it somewhere. I am not a programmer, so I have no clue how to write a backend for sane.
I am asking in a lot of directions also HP about it. I always get negative answers.
I am by myself an employee of HP and I see it like this:
The community who is using Linux as an OS is growing and growing. I heard also that more than 20.000 people in HP are using Linux. So it starts to be important to have drivers for the latest hardware also for Linux. Have a look at Nvidia for example. They have actual drivers for there latest products. Why a company like HP is not able to satisfy customers with a Linux based hardware driver?
As an HP employee I am not able to decide something like an Epson Scanner, sorry.
If there is somewhere the possibility to write a driver for sane, or include it in the HPLib, please do....

Kind regrads

Lowrider

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Aaron Albright (albrigha-deactivatedaccount) said :
#1

The HP Linux Imaging and Printing project does not support any HP ScanJet devices. All ScanJet support is provided by the Sane Project.

It appears that the G4050 isn't supported by Sane either:

http://www.sane-project.org/unsupported/hp-g4050.html

You may want to contact the Sane project for more information.

Sorry for the inconvenience.

Aaron

Can you help with this problem?

Provide an answer of your own, or ask Lowrider for more information if necessary.

To post a message you must log in.