hp officejet 6000 hplib needed. error on install

Asked by Matt_Fontana

error message: error: A required dependency 'gcc (gcc - GNU Project C and C++ Compiler)' is still missing.
error: Installation cannot continue without this dependency.
error: Please manually install this dependency and re-run this installer

It said i had a prevous version of hplib and went to uninstall it and i got that error. I am new to ubuntu and i will need sort of step by step directions.

I am trying to install a hp inkjet 6000 w/ Wireless (E609N) on ubuntu 8.10. I tried installing: hplip-3.9.8.run

Thank you for helping me.

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Aaron Albright (albrigha-deactivatedaccount) said :

Try running:

sudo apt-get install build-essential

then run the installer again. Does that help?


Revision history for this message
Matt_Fontana (chessboy500) said :

matt@matt-laptop:~/Desktop$ sudo apt-get install build-essential
[sudo] password for matt:
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

This is what happened when I typed that code.
However, looking it over i also found this:

Running 'sudo aptitude install --assume-yes build-essential'
Please wait, this may take several minutes...
warning: A previous install of HPLIP is installed and/or running.
sudo apt-get remove --assume-yes hplip hpijs foomatic-db-hpijs (Removing old HPLIP version)
warning: HPLIP removal failed. The previous install may have been installed using a tarball or this installer.
warning: Continuing to run installer - this installation should overwrite the previous one.

Revision history for this message
Aaron Albright (albrigha-deactivatedaccount) said :

In the HPLIP source directory run:


and post the output.



Revision history for this message
Matt_Fontana (chessboy500) said :

LOL i dont really get it i tried running it one more time to just be sure and this time it worked i can't explain maybe the gcc package somehow got installed? I don't really know how it happened, but thanks so much for the help you were absolutely great.