hp-toolbox and hp-check errors on debian testing

Asked by westerngateguard

hplip, hplip-gui, hpijs, hplip-data, hpijs-ppds installed from repository (v.3.9.4b-1)

yigal:/home/yigal# hp-toolbox
error: Unable to locate models.dat file
warning: hp-toolbox should not be run as root/superuser.

HP Linux Imaging and Printing System (ver. 0.0.0)
HP Device Manager ver. 15.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Fax disabled.
error: Fax disabled.
warning: Please install version 2.0+ of Reportlab for coverpage support.
error: Unable to locate models.dat file
Xlib: extension "RANDR" missing on display ":0.0".
Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
error: Pixmap 'plus.png' not found!
error: Pixmap 'minus.png' not found!
error: dBus initialization error. Exiting.
error: Pixmap 'hp_logo.png' not found!
error: Pixmap 'fax2.png' not found!
error: Pixmap 'refresh1.png' not found!
error: Pixmap 'refresh.png' not found!
error: Pixmap 'list_add.png' not found!
error: Pixmap 'list_remove.png' not found!
error: Pixmap 'settings.png' not found!
error: Pixmap 'help.png' not found!
error: Pixmap 'quit.png' not found!
error: Pixmap 'battery.png' not found!
error: Pixmap 'cancel.png' not found!
error: Pixmap 'refresh.png' not found!
error: Pixmap 'busy.png' not found!
error: Pixmap 'busy.png' not found!
error: Pixmap 'print.png' not found!
error: Pixmap 'warning.png' not found!
error: Pixmap 'warning.png' not found!
error: Pixmap 'error.png' not found!
error: Pixmap 'ok.png' not found!

yigal:/home/yigal# hp-check -r
error: Unable to locate models.dat file

HP Linux Imaging and Printing System (ver. 0.0.0)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to
determine if the proper dependencies are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built
HPLIP supplied tarball has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and
run-time dependencies).

Saving output in log file: hp-check.log

Initializing. Please wait...
\Traceback (most recent call last):
  File "/usr/bin/hp-check", line 199, in <module>
    core.init()
  File "/usr/share/hplip/installer/core_install.py", line 428, in init
    self.distro_name = self.distros_index[self.distro]
KeyError: 0

Please ask what additional information you need.

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Aaron Albright (albrigha-deactivatedaccount) said :
#1

We do not test the Debian created HPLIP packages.

Please uninstall HPLIP and install the latest from http://hplipopensource.com

Hope this helps.

Aaron

Can you help with this problem?

Provide an answer of your own, or ask westerngateguard for more information if necessary.

To post a message you must log in.