encounter configure: error: cannot find net-snmp support (or --disable-network-build) while installing hplip-3.9.8

Asked by always hp

Centos 5.3 i386 32bit version
Photosmart C4599

output:

[root@localhost ~]# hp-check -t

HP Linux Imaging and Printing System (ver. 1.6.7)
Dependency/Version Check Utility ver. 2.1

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Check the existence and versions of HPLIP dependencies.

Usage: hp-check [OPTIONS]

[OPTIONS]
  Set the logging level: -l<level> or --logging=<level>
                                <level>: none, info*, error, warn, debug (*default)
  Run in debug mode: -g (same as option: -ldebug)
  This help information: -h or --hel

I've followed
http://hplipopensource.com/hplip-web/install/install/index.html

I encounter the problem in

[code]
Step 10: './configure' and 'make' will run

[doordie@localhost hplip-3.9.8]$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
...
checking for CRYPTO_free in -lcrypto... no
configure: error: cannot find net-snmp support (or --disable-network-build)

[/code]
https://answers.launchpad.net/hplip/+question/70919
Aaron Albright mentioned installed net-snmp-devel package

so I have installed net-snmp-devl, it still could not resolve my issues, how could I proceed from here?

Installed: net-snmp-devel.i386 1:5.3.2.2-5.el5_3.1
Dependency Installed: beecrypt.i386 0:4.1.2-10.1.1 beecrypt-devel.i386 0:4.1.2-10.1.1 elfutils-devel.i386 0:0.137-3.el5 elfutils-devel-static.i386 0:0.137-3.el5 elfutils-libelf-devel.i386 0:0.137-3.el5 elfutils-libelf-devel-static.i386 0:0.137-3.el5 elfutils-libs.i386 0:0.137-3.el5 libselinux-devel.i386 0:1.33.4-5.1.el5 libsepol-devel.i386 0:1.15.2-1.el5 nspr-devel.i386 0:4.7.4-1.el5_3.1 nss-devel.i386 0:3.12.3.99.3-1.el5.centos.2 rpm-devel.i386 0:4.4.2.3-9.el5 sqlite-devel.i386 0:3.3.6-2
Updated: nspr.i386 0:4.7.4-1.el5_3.1 nss.i386 0:3.12.3.99.3-1.el5.centos.2 nss-tools.i386 0:3.12.3.99.3-1.el5.centos.2
Complete!
[root@localhost ~]# hp-check -t

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Aaron Albright (albrigha-deactivatedaccount) said :
#1

Rather than trying to install from source, try using the RHEL 5 RPM and see if that works for you. It should work with CentOS 5.

You can get the RPM here:

http://hplipopensource.com/hplip-web/install_wizard/index.html

Thanks for your support of HPLIP--we appreciate it.

Aaron

Revision history for this message
ubuntunewbie (rhcewannabe) said :
#2

I've done the following,

su -c 'make uninstall'

later I do a rpm -Uvh

[root@localhost hplip]# rpm -Uvh hplip-3.9.8_rhel-5.0.i386.rpm
Preparing... ########################################### [100%]
        file /usr/lib/libhpip.so.0.0.1 from install of hplipfull-3.9.8.34.internal-0.i386 conflicts with file from package hpijs-1.6.7-4.1.el5.4.i386
        file /etc/hp/hplip.conf from install of hplipfull-3.9.8.34.internal-0.i386 conflicts with file from package hplip-1.6.7-4.1.el5.4.i386

but it don't everything don't seem to work now.....

Revision history for this message
Naga Samrat Chowdary, Narla (samrat-hplip) said :
#3

You need to install openssl-devel RPM package to rectify the error for --disable-network-build

Hope this helps,
Naga Samrat.

Can you help with this problem?

Provide an answer of your own, or ask always hp for more information if necessary.

To post a message you must log in.