can not print on both sides of a page

Asked by sconymac

Hello Guys:

I am having problems with auto-duplexing with my Officejet 6500 e709N
This function was working properly but I recently formated this PC.
I have installed the latest version of HPLIP <vers 3.9.6b> and have it
configured it properly.

I have gone through the driver throughly and now have come to the
conclusion that the driver may not be functioning properly. I can only print
single sided from all applications. OpenOffice writer, Firefox, ETC. I

Please help. I have been using your product for awhile now and have come to
love it, if you can help me with this one small issue it will be working perfectly
and I can sing praises all over the Internet.

Information is as follows:

Linux Distro OpenSuse 11.1
Printer make / model Officejet 6500 E709N
HPLIP Vers 3.9.6b

To recreate the problem install HPLIP <vers 3.9.6b>
using suse 11.1 and attempt duplex printing from any application.

Output of hp -check -t:

Emerald@linux-carhar:~> hp-check -t

HP Linux Imaging and Printing System (ver. 3.9.6b)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied
tarball (.tar.gz or .run) to determine if the proper dependencies are installed to successfully
compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package
(.deb, .rpm, etc) or an already built HPLIP supplied tarball has the proper dependencies
installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of
the above cases (both compile- and run-time dependencies).

Saving output in log file: hp-check.log

Initializing. Please wait...

---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux linux-carhar 2.6.27.25-0.1-pae #1 SMP 2009-07-01 15:37:09 +0200 i686 i686 i386 GNU/Linux

Distribution:
suse 11.1

Checking Python version...
OK, version 2.6.0 installed

Checking PyQt 4.x version...
OK, version 4.4.3 installed.

Checking for CUPS...
Status: scheduler is running
Version: 1.3.9
warning: /etc/cups/cupsd.conf file not found or not accessible.

Checking for dbus/python-dbus...
dbus daemon is running.
python-dbus version: 0.83.0

------------------------------------
| COMPILE AND RUNTIME DEPENDENCIES |
------------------------------------

note: To check for compile-time only dependencies, re-run hp-check with the -c parameter (ie, hp-check -c).
note: To check for run-time only dependencies, re-run hp-check with the -r parameter (ie, hp-check -r).

Checking for dependency: CUPS - Common Unix Printing System...
OK, found.

Checking for dependency: CUPS DDK - CUPS driver development kit...
OK, found.

Checking for dependency: CUPS devel- Common Unix Printing System development files...
OK, found.

Checking for dependency: CUPS image - CUPS image development files...
OK, found.

Checking for dependency: DBus - Message bus system...
OK, found.

Checking for dependency: gcc - GNU Project C and C++ Compiler...
OK, found.

Checking for dependency: GhostScript - PostScript and PDF language interpreter and previewer...
OK, found.

Checking for dependency: libcrypto - OpenSSL cryptographic library...
OK, found.

Checking for dependency: libjpeg - JPEG library...
OK, found.

Checking for dependency: libnetsnmp-devel - SNMP networking library development files...
OK, found.

Checking for dependency: libpthread - POSIX threads library...
OK, found.

Checking for dependency: libtool - Library building support services...
OK, found.

Checking for dependency: libusb - USB library...
OK, found.

Checking for dependency: make - GNU make utility to maintain groups of programs...
OK, found.

Checking for dependency: PIL - Python Imaging Library (required for commandline scanning with hp-scan)...
OK, found.

Checking for dependency: PolicyKit - Administrative policy framework...
warning: NOT FOUND! This is an OPTIONAL/RUNTIME ONLY dependency. Some HPLIP functionality may not function properly.

Checking for dependency: PyQt 4 DBus - DBus Support for PyQt4...
OK, found.

Checking for dependency: Python DBus - Python bindings for DBus...
OK, found.

Checking for dependency: Python devel - Python development files...
OK, found.

Checking for dependency: Python libnotify - Python bindings for the libnotify Desktop notifications...
warning: NOT FOUND! This is an OPTIONAL/RUNTIME ONLY dependency. Some HPLIP functionality may not function properly.

Checking for dependency: Python XML libraries...
OK, found.

Checking for dependency: Python 2.3 or greater - Required for fax functionality...
OK, found.

Checking for dependency: Python 2.2 or greater - Python programming language...
OK, found.

Checking for dependency: Reportlab - PDF library for Python...
OK, found.

Checking for dependency: SANE - Scanning library...
OK, found.

Checking for dependency: SANE - Scanning library development files...
OK, found.

Checking for dependency: scanimage - Shell scanning program...
OK, found.

Checking for dependency: xsane - Graphical scanner frontend for SANE...
OK, found.

----------------------
| HPLIP INSTALLATION |
----------------------

Currently installed HPLIP version...
HPLIP 3.9.6b currently installed in '/usr/share/hplip'.

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.9.6b

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/cups/model/manufacturer-PPDs/hplip
ppdbase=/usr/share/cups/model/manufacturer-PPDs
doc=/usr/share/doc/packages/hplip
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=no
cups-ppd-install=yes
internal-tag=3.9.6b.4
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=yes
hpijs-only-build=no
lite-build=no

Current contents of '/var/lib/hp/hplip.state' file:
# hplip.state - HPLIP runtime persistent variables.

[plugin]
installed=0
eula=0

Current contents of '~/.hplip/hplip.conf' file:
[last_used]
printer_name = Officejet_6500_E709n
working_dir = .
device_uri = "hp:/net/Officejet_6500_E709n?ip=192.168.1.66"

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[installation]
version = 3.9.6b.4
date_time = 07/28/09 15:28:48

[settings]
systray_messages = 0
systray_visible = 0

[fax]
email_address =
voice_phone =

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
device_list =
interval = 5

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

Officejet_6500_E709n
--------------------
Type: Printer
Device URI: hp:/net/Officejet_6500_E709n?ip=192.168.1.66
PPD: /etc/cups/ppd/Officejet_6500_E709n.ppd
PPD Description: HP Officejet 6500 e709n, hpcups 3.9.6b
Printer status: printer Officejet_6500_E709n is idle. enabled since Tue 28 Jul 2009 03:03:56 PM CDT
Communication status: Good

Officejet_6500_E709n_fax
------------------------
Type: Fax
Device URI: hpfax:/net/Officejet_6500_E709n?ip=192.168.1.66
PPD: /etc/cups/ppd/Officejet_6500_E709n_fax.ppd
PPD Description: HP Fax hpcups
Printer status: printer Officejet_6500_E709n_fax is idle. enabled since Thu 23 Jul 2009 08:07:14 PM CDT
Communication status: Good

----------------------
| SANE CONFIGURATION |
----------------------

'hpaio' in '/etc/sane.d/dll.conf'...
OK, found. SANE backend 'hpaio' is properly set up.

Checking output of 'scanimage -L'...
device `hpaio:/net/Officejet_6500_E709n?ip=192.168.1.66' is a Hewlett-Packard Officejet_6500_E709n all-in-one

---------------------
| PYTHON EXTENSIONS |
---------------------

Checking 'cupsext' CUPS extension...
OK, found.

Checking 'pcardext' Photocard extension...
OK, found.

Checking 'hpmudext' I/O extension...
OK, found.

Checking 'scanext' SANE scanning extension...
OK, found.

---------------
| USER GROUPS |
---------------

users dialout video

-----------
| SUMMARY |
-----------

error: 2 errors and/or warnings.

Please refer to the installation instructions at:
http://hplip.sourceforge.net/install/index.html

Done.

Please Reply To my email address <email address hidden>
Thanks in advance

Mike Sconyers

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Aaron Albright (albrigha-deactivatedaccount) said :
#1

When printing duplex please be sure to select the paper size Letter/A4 Autoduplex. If you do not then duplex will not work.

Hope this helps!

Aaron

Revision history for this message
sconymac (mikescony1) said :
#2

Hello Aaron:

Sorry that does not work. I have tried those setting in the HP device manager and printer properties, Still no duplex function.

Revision history for this message
sconymac (mikescony1) said :
#3

Hello Guys:

Futher information that may help:

I have gone over the cups driver itself <localhost:631>
and changed the duplexer settings and media settings
still the problem persists.

I have looked over the cupsd.conf < /etc/cups/cupsd.conf >
and printer.conf < /etc/cups/printers.conf >

I also looked at the lpoptions file located at /home/user/.cups
this file was set to duplex=notumble I don't know if modifying this
file will solve the problem. Please advise.

Looking forward to your input.
Mike
<email address hidden>

Revision history for this message
sconymac (mikescony1) said :
#4

Hello Guys:

FYI: I Downgraded hplip from 3.9.6b to 3.9.4b < this was the minimum vers that was compatable >
and WAH - LAH That works. Duplex printing is now working. That still does not fix the problem
with the new version, but this information can be used as starting point for troubleshooting ( ehhh )

Looking forward to your input
Mike
<email address hidden>

Revision history for this message
Linus Araque (linus-araque) said :
#5

Hi Mike -

I'm unable to reproduce this problem in SuSE 11.1. I'm using 3.9.6b with a OfficeJet 6500 e709n. What CUPS options are you setting via localhost? Under my general tab, I'm setting Media Size to Letter Autoduplex, Double sided printing is set to long edge (standard) the rest of the options are left as defaults. Under Options Installed, I'm setting duplexer to installed.

Thank you for supporting HPLIP.
-Linus

Revision history for this message
sconymac (mikescony1) said :
#6

Hello Linus:

Sorry for the late response, I was using those exact settings using the HP device manager and manually using CUPS <HTTP://localhost:631> Still I was unable to use double sided printing. This may have just been some kind of download hic-cup, because I installed an earlier version of HPLIP <see above> and that is working fine without the additional settings for media size, ETC.

Revision history for this message
Linus Araque (linus-araque) said :
#7

Mike -

It sounds like 3.9.4b suits your needs. The only other thing I could suggest is upgrading to 3.9.8, but if you're satisfied with the functionality provided by 3.9.4b, I'd say stick with it.

Thank you for your support.
-Linus

Can you help with this problem?

Provide an answer of your own, or ask sconymac for more information if necessary.

To post a message you must log in.