not able to download drivers to complete instalation

Asked by Carlos Pineda

I am running on gentoo. I installed the package hplip. Afterwards I run:
~ # hp-setup

The program correctly detects my HP Laserhet p1005 printer at USB,
and advices me to download from the internet the driver.
However it does not find the host [ERROR: Plug-in file not found (server returned 404 or similar error).
Error code: (-3, 'Temporary failure in name resolution')]. Is there an alternative place from which I can download the driver?


Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Aaron Albright
Last query:
Last reply:
Revision history for this message
Best Aaron Albright (albrigha-deactivatedaccount) said :

You can download the plugin manually by going here:

then download the version that matches the version of HPLIP you are using and run the .run file using ./<filename>.run


Revision history for this message
Carlos Pineda (carlospgmat03) said :

Thanks, it seemed that the server was down. Yesterday after many teers, I was able to make my printer work. However it was more painfull than with other HPs with which I have worked. Thank you very much for support!

Revision history for this message
Carlos Pineda (carlospgmat03) said :

Thanks Aaron Albright, that solved my question.