hplip-3.9.4 does not see hp jet direct 170x

Asked by picgla

I have just upgraded to 3.9.4 from 2.8.10. Now, hplip no longer recognizes my jet direct 170x. My searches in the archives have turned up no similar cases. CUPS sees the jet direct and manages the printer (T45xi) with no problems. hp-check gives the following relevant output:

Type: Unknown
Device URI: socket://
PPD: /etc/cups/ppd/t45xi.ppd
PPD Description: HP OfficeJet T45 - CUPS+Gutenprint 5.2.0-rc1
Printer status: printer t45xi is idle. enabled since Mon May 11 14:31:13 2009
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend to function in HPLIP.

Does anyone have suggestions for further diagnostics or bugtracking?

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Aaron Albright
Last query:
Last reply:
Revision history for this message
Best Aaron Albright (albrigha-deactivatedaccount) said :

Please use hp-setup to configure the printer. The printer must be using the hp:/ backend.


Revision history for this message
picgla (picgla) said :

hp-setup did indeed successfully add the printer. Thank you very much.

Revision history for this message
picgla (picgla) said :

Thanks Aaron Albright, that solved my question.