Cannot download HPLIP plugin

Asked by Naropa Craske

I have Linux Mint Vera installed on my PC which has HPLIP 3.21.12.
I have just bought a Deskjet 2700e and installed it successfully using a USB connection.

However when I try to scan from my PC, it tells me that I need a plugin and when I tell it to download, it says :-
"Checking for Network connection" but never goes any further, despite the fact that I have a very strong WiFi signal and I can still access the internet with my browser and Update Manager. I have tried disabling the firewall and my VPN but this doesn't change anything.

I have also found the scripts of .ASC and .RUN for doing the job manually but I don't know how to get them to run.

Please can you advise me how to proceed


Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :

Download the file by doing a right click on the link and selecting "save target as ..." and store it in the Downloads folder

Then open a terminal window and execute the commands

cd Downloads
sh ./

Revision history for this message
Naropa Craske (naropacraske) said :

Sorry. I dont have "Save Target as" when I right click the link.

So. How can I save it?



Revision history for this message
Naropa Craske (naropacraske) said :

Sorted Now



Revision history for this message
Naropa Craske (naropacraske) said :

Thanks Manfred Hampl, that solved my question.