HPLIP install terminates/fails in Ubuntu 22.04 due to missing dependencies.

Asked by Tim Souther

The HPLIP installation seems to run smoothly until errors are produced due to three required dependencies that are missing. The three dependencies are:

- libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)
- libcrypto (libcrypto - OpenSSL cryptographic library)
- python3-pyqt5 (PyQt 5 interface for Python for Qt version 4.x))

Following these error messages, the following messages are produced in Terminal:

"error: Installation cannot continue without these dependencies."
"error: Please manually install this dependency and re-run this installer."

I am not sure how to obtain/install the dependencies indicated. Would they be in repositories to which I'm not connected? If so I'm confused as to how to connect to them. If not... ?

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Tim Souther
Last query:
Last reply:
Revision history for this message
brian_p (claremont102) said :

What is the printer model and connection method?

Revision history for this message
Tim Souther (befreeil) said :

Printer model is HP DeskJet 2700 All-in-One connected through wifi. However. this is just an attempt to install the HPLIP System. Until successfully installed I won't identify the printer to it. At this stage in the process the printer model won't matter. I do know that it is one of the listed/recognized HP printers.

Revision history for this message
brian_p (claremont102) said :



The output is a URI. Substitute for it in

  lpadmin -p deskjet2700 -v "URI" -E -m everywhere

Test printing with

  lp -d deskjet2700 /etc/nsswitch.conf

Revision history for this message
Tim Souther (befreeil) said :

@brian_p Thanks. I would have done that if I hadn't found the solution to installing the HPLIP app in the "Problem Solve" post that will follow this one. I will hold on to those commands just in case I run into trouble actually using the HP app.

Revision history for this message
Tim Souther (befreeil) said :

I found the solution to the HPLIP installation failure that is the subject of this query....

So, the problem was that dependency files were not being installed. I found that I only had the "Main" repository turned on for downloading. When I turned on the other three (Universe, Restricted & Multiverse), under About (Software & Updates/Ubuntu Software, the installation proceeded without a hitch and the HP Printer app was successfully installed.

Unfortunately, after a mandatory Restart, even though I was still connected to my network, for some as yet unknowns reason, I no longer had a connection to the Internet (even though all other devices connected to the network did), nor could my Linux/Ubuntu 22.04 find the HP DeskJet 2700 All-in-One printer. As a result I have not been able to properly test the HP software.