Can't find HPLIP driver package for Oracle Linux 8 distro

Asked by Ryan Forman

We're running Oracle Linux 8 (Oracle Linux Server 8.7, I believe). I ran "sudo dnf install hplip*" and "sudo yum install hplip*". CUPS was already installed with this OS. I tried to find/setup an HP Color LaserJet Pro MFP M479fdw network printer. This didn't work. I checked the supported printers, and it is supported, but only with HPLIP 13.9.6 and above. The HPLIP available in the yum repository is 13.8.x. When I ran "lpinfo --make-and-model m", this model of HP printer doesn't show up. So, I believe that explains why it isn't found, I don't have the drivers for it. I manually went to the HPLIP site to download the HPLIP updated drivers, and you must select a distro and version. Oracle Linux is not an option. I tried selecting other, and running the .run file, but it immediately came up and said oracle wasn't a recognized distro and to proceed with caution, so I stopped running it.

Can you help me find the correct updated drivers for Oracle Linux, if they exist, and any info on how to install them? Thanks very much.

-Ryan Forman
<email address hidden>

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
brian_p (claremont102) said :

The solutions at

avoid using HPLIP and are easy to implement. A network
connection is straightforward. USB requires ipp-usb.

Can you help with this problem?

Provide an answer of your own, or ask Ryan Forman for more information if necessary.

To post a message you must log in.