No system tray detected on this system

Asked by Per Anton Rønning

System: Host: par-H310M-HDV-M2 Kernel: 5.4.0-131-generic x86_64 bits: 64 Desktop: MATE 1.26.0 Distro: Linux Mint 20.3 Una based on Ubuntu 20.04.5

HPLIP did work fine after upgrading to Mint 20.3. Suddenly, after a reboot, the HPLIP icon had disappeared from the toolbar, and the HPLIP GUI Toolbox
"Actions" only contained:
1) UPS View Printer and Device information
2) Visit HPLIP Support website
3) ? Help
It was cut short.

HPLIP version is 3.21.8

The printer no longer responds to any attempts to print.

After reboot a message box is displayed containing the message shown in the subject line: "No system tray detected on this system"
Running ps ax | grep hp- shows:
1821 ? Ssl 0:01 /usr/bin/python3 /usr/bin/hp-systray -x
1878 ? S 0:00 /usr/bin/python3 /usr/bin/hp-systray -x
1879 ? Sl 0:00 /usr/bin/python3 /usr/bin/hp-systray -x

i.e. 3 processes named hp-systray have been started. Why 3 processes?

The command hp-systray -x is included in startup applications,
but it has disappeared from the toolbar at the bottom of the screen.

I also get a message that the printer may not be connected when trying to print a Test Page,
but I fail to see how that could be.

$ lpq
DeskJet_2700 is ready and printing

this should indicate that the system is detecting the printer.

I did attempt (as mentiones above) to print a Test Page from the control center/printers which contains the installed printer, but nothing was printed .

I have studied other questions/answers to similar problems, but I have failed to find any answers there which have solved this problem.
I have tried several searches for answers in Google and Mint Forum, but I am stuck.

The crux of the matter is: The hp-systray is running, so why is not the system tray detected???

I hope someone may point me in the right direction, there is obviously something I have not thought about. Usually printing works fine, so there has been no need to explore the topic. I usually work on a need to know basis when it comes to the system software, I prefer to concentrate on applications.

NB! I have tried to install the latest HPLIP version, but another post here describes how that failed.

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Per Anton Rønning
Last query:
Last reply:
Revision history for this message
Per Anton Rønning (pronn) said :

I managed to install HPLIP 3.22.10, and that took care of the problem.