HP Linux Imaging and Printing

hplip can't find Python.h

Asked by sercik on 2009-05-08

Hi to all!
I hope someone can help me..
I have compiled and installed from source python 2.6 and some other modules like dbus pygtk pygobiect etc, etc,
I have installed all under /opt because i don't want to create problem to my system...
my distribution uses python 2.4 that to me seems old for this i have installed python 2.6.

to compile hplip i do export PYTHON=/opt/bin/python2.6
and then i do

./configure --with-hpppddir=/usr/share/cups/model/HP --prefix=/opt --disable-qt4 --enable-doc-build --enable-qt3 --disable-pp-build --disable-foomatic-drv-install --enable-foomatic-ppd-install --enable-network-build --enable-dbus-build --disable-hpijs-only-build --enable-scan-build --enable-fax-build

during configure i obtain:

checking for path to Python.h... "using /opt/include/python2.6"
checking python2.6/Python.h usability... no
checking python2.6/Python.h presence... no
checking for python2.6/Python.h... no
configure: error: cannot find python-devel support

this is strange because Python.h exists under /opt/include/python2.6 as you can see below:

[root@system hplip-3.9.2]# ll /opt/include/python2.6/Pyt*
-rw-r--r-- 1 root root 20081 3 mag 10:47 /opt/include/python2.6/Python-ast.h
-rw-r--r-- 1 root root 4384 3 mag 10:47 /opt/include/python2.6/Python.h

what can i do?
sercik

<email address hidden>

Question information

Language:
English Edit question
Status:
Expired
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2009-05-12
Last reply:
2009-05-28

What distro are you using?

In the HPLIP source directory run ./check.py and post the output.

Thanks.

Aaron

sercik (aspcicc) said : #2

Hi Aaron! and thanks for your interest.
i'm using clarkconnect based on centos 5.3

this is the output of check.py
warning: CUPSEXT could not be loaded. Please check HPLIP installation.

but i don't understand why do you need that.. hplip is not installed for now
i'm trying to compile it linked to python2.6 that i have under /opt

Andrew Malcolmson (andmalc) said : #3

HPLIP requires Python 2.2 you could install HPLIP from the package manager instead of from source and allow it to use Python 2.4 as provided by your system (I'm assuming that this is installed by default on Clark Connect).

Aaron can correct me if I'm wrong but I believe Python is used for the printer management applications only, and so whatever speed benefit Python 2.6 has over 2.4 isn't really worth the extra work.

sercik (aspcicc) said : #4

ok
i know that i can install hplip from my distribution.
but centos daosn't support hplip if i remember, than i'd like ro install newer version of hplip..
and i'd like to compile over python2.6

so if you can help me to solve the error ok otherwise thanks but don't post..

I think that my problem is important to solve because i suspect a hplip bug: is not possible that configure is not able to see a file that exists at least if it search for him in the right location.

The CUPSEXT error usually means that there is more than one version of python installed and HPLIP is trying to use the wrong one.

You can look over this document for some hints:

http://hplipopensource.com/node/323

Aaron

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.