printer hp p1102 "hp-plugin" unsuccessfull

Asked by bernd kunz

My problem seems to be related to the new OS Debian11 I installed, because the printer worked perfectly with the older OS Debian9.9 from year 2019, at that time with no manual interaction.
 The installation of HPLIP now ended with no errors. On the HP-sites it is indicated, that a plugin is required for this printer,
( HP_Laserjet_Professional P1102 ) , which should be supported according to the HP-listing. "hp-setup" successfull.
Running "hp-plugin" as user ends with:
in check_network_via_ping ; log.debug("ping returned:%d "status) ; Type error: %d format: a number is require, not NoneType
As this program claims to be automatic, what can I do?
I deeply appreciate your answer.
Sincerely yours
B.Kunz , Munich, Germany
<email address hidden>

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :
Revision history for this message
bernd kunz (berndlin) said :

But this is not my printer. Mine is HP Laserjet Professional P1102, with
Linux Debian11.5,
HPLIP3.21.2+dfsg1-2_amd64. I did run "hp-setup" and "hp-plugin" which ends
with an error-message.
Best regards

On Mon, Nov 21, 2022 at 8:50 AM Manfred Hampl <
<email address hidden>> wrote:

> Your question #703882 on HPLIP changed:
> Status: Open => Answered
> Manfred Hampl proposed the following answer:
> see
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> You received this question notification because you asked the question.

Revision history for this message
Best Manfred Hampl (m-hampl) said :

Type of the printer and operating system are not relevant. Important are the steps described in comment #1 of the linked question:

Download the file by doing a right click on the link and selecting "save target as ..." and store it in the Downloads folder

Then open a terminal window and execute the commands

cd Downloads
sh ./

Revision history for this message
bernd kunz (berndlin) said :

The plugin-version did not work, as it recognized the hplip-version i got through "apt-get" as hplip3.22.10 . But
applying the way you proposed with plugin3.22 ( from the hp-developers-page ) the problem could be solved.
Thank you very much!
Best regards