HP Printer plugin installation issue in Ubuntu 22.04

Asked by Shrikanth Kamath

here below is the Terminal output for the Command 'hp-check -t'

/usr/bin/hp-check:685: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  if 'getfacl' not in g and '' is not g and 'file' not in g:
Saving output in log file: /home/shrikanth/hp-check.log

HP Linux Imaging and Printing System (ver. 3.22.6)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

(xsane:7169): Gtk-WARNING **: 17:24:49.012: Unable to locate theme engine in module_path: "hcengine",
Gtk-Message: 17:24:49.013: Failed to load module "canberra-gtk-module"

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.15.0-47-generic #51-Ubuntu SMP Thu Aug 11 07:51:15 UTC 2022 GNU/Linux
 Host: shrikanth-HP-Notebook
 Proc: 5.15.0-47-generic #51-Ubuntu SMP Thu Aug 11 07:51:15 UTC 2022 GNU/Linux
 Distribution: 12 22.04
 Bitness: 64 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.22.6
HPLIP-Home: /usr/share/hplip
HPLIP-Installation: Auto installation is supported for ubuntu distro 22.04 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.22.6

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.22.6
html=/usr/share/doc/hplip-3.22.6
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.22.6
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=yes
class-driver=no

Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[fax]
email_address =
voice_phone =

[last_used]
device_uri = "hp:/usb/HP_LaserJet_1020?serial=S40STSQ"
printer_name =
working_dir = /home/shrikanth/Downloads/hplip-3.22.6.run

[polling]
device_list =
enable = false
interval = 5

[refresh]
enable = false
rate = 30
type = 1

[settings]
systray_messages = 0
systray_visible = 0

[upgrade]
last_upgraded_time = 1662893149
notify_upgrade = true
pending_upgrade_time = 0

[installation]
date_time = 09/11/22 17:24:50
version = 3.22.6

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

-------------------------
| External Dependencies |
-------------------------

 cups CUPS - Common Unix Printing System REQUIRED 1.1 2.4.1 OK 'CUPS Scheduler is running'
 gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.55.0 OK -

(xsane:7278): Gtk-WARNING **: 17:24:51.063: Unable to locate theme engine in module_path: "hcengine",
Gtk-Message: 17:24:51.065: Failed to load module "canberra-gtk-module"

(xsane:7280): Gtk-WARNING **: 17:24:51.097: Unable to locate theme engine in module_path: "hcengine",
Gtk-Message: 17:24:51.098: Failed to load module "canberra-gtk-module"
 xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
 scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.1.1 OK -
 dbus DBus - Message bus system REQUIRED - 1.12.20 OK -
 policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
 network network -wget OPTIONAL - 1.21.2 OK -
 avahi-utils avahi-utils OPTIONAL - 0.8 OK -

------------------------
| General Dependencies |
------------------------

 libjpeg libjpeg - JPEG library REQUIRED - - OK -
 cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.4.1 OK -
 cups-image CUPS image - CUPS image development files REQUIRED - 2.4.1 OK -
 libpthread libpthread - POSIX threads library REQUIRED - b'2.35' OK -
 libusb libusb - USB library REQUIRED - 1.0 OK -
 sane SANE - Scanning library REQUIRED - - OK -
 sane-devel SANE - Scanning library development files REQUIRED - - OK -
 libavahi-dev libavahi-dev REQUIRED - - OK -
 libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.9.1 OK -
 libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 3.0.2 OK -
 python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.10.4 OK -
 python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
 python3-pyqt5-dbus PyQt 5 DBus - DBus Support for PyQt5 OPTIONAL 5.0 5.15.6 OK -
 python3-pyqt5 PyQt 5- Qt interface for Python (for Qt version 4.x) REQUIRED 5.0 5.15.6 OK -
 python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.18 OK -
 python3-xml Python XML libraries REQUIRED - 2.4.7 OK -
 python3-devel Python devel - Python development files REQUIRED 2.2 3.10.4 OK -
 python3-pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 9.0.1 OK -
 python3-reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.6.8 OK -

--------------
| COMPILEDEP |
--------------

 libtool libtool - Library building support services REQUIRED - 2.4.6 OK -
 gcc gcc - GNU Project C and C++ Compiler REQUIRED - 11.2.0 OK -
 make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.3 OK -

---------------------
| Python Extentions |
---------------------

 cupsext CUPS-Extension REQUIRED - 3.22.6 OK -
 hpmudext IO-Extension REQUIRED - 3.22.6 OK -

----------------------
| Scan Configuration |
----------------------

 hpaio HPLIP-SANE-Backend REQUIRED - 3.22.6 OK 'hpaio found in /etc/sane.d/dll.conf'
 scanext Scan-SANE-Extension REQUIRED - 3.22.6 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI Model
  -------------------------------- ----------------
  hp:/usb/HP_LaserJet_1020?serial= HP LaserJet 1020
  S40STSQ

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

HP-LaserJet-1020
----------------
Type: Printer
Device URI: hp:/usb/HP_LaserJet_1020?serial=S40STSQ
PPD: /etc/cups/ppd/HP-LaserJet-1020.ppd
warning: Failed to read /etc/cups/ppd/HP-LaserJet-1020.ppd ppd file
PPD Description:
Printer status: printer HP-LaserJet-1020 is idle. enabled since Sunday 11 September 2022 04:53:26 PM
error: Required plug-in status: Not installed
Communication status: Good

--------------
| PERMISSION |
--------------

USB HP-LaserJet-1020 Required - - OK Node:'/dev/bus/usb/001/005' Perm:' root lp rw- rw- rw- rw- rw- r--'

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
None

Plug-in Status
--------------
error: Plug-ins need to be installed

Total Errors: 1
Total Warnings: 0

Done.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
Last query:
Last reply:
Revision history for this message
Shrikanth Kamath (kskamath) said :
#1

Another message flashed when using the hplip gui - 'File does not match its checksum. File may have been corrupted or altered.'

i get this message whenever i try to install the plugin using the gui

Revision history for this message
Best Manfred Hampl (m-hampl) said :
#2

Try the following:

Download the file https://developers.hp.com/sites/default/files/hplip-3.22.6-plugin.run by doing a right click on the link and selectin "save target as ..." and store it in the Downloads folder

Then open a terminal window and execute the commands

cd Downloads
sh ./hplip-3.22.6-plugin.run

Revision history for this message
Shrikanth Kamath (kskamath) said :
#3

Thank you Manfred, following your instructions i could successfully install the required plugin, and am now able to use the printer. I am grateful for your help. I appreciate the swift response, as well.

Revision history for this message
Shrikanth Kamath (kskamath) said :
#4

Thanks Manfred Hampl, that solved my question.

Revision history for this message
Karthikeyan.s.s (karthivyas) said :
#5

Thank you Srikanth & Manfred Hampl. To both have raised question & given solution.

Revision history for this message
Tim Souther (befreeil) said (last edit ):
#6

I have modified Manfred Hampl's link to hplip-3.22.10-plugin.run so that the current file may be saved. So, here it is...
https://developers.hp.com/sites/default/files/hplip-3.22.10-plugin.run
Likewise, the command should be changed from .6 to .10.
Update:
This enabled me to successfully install the plugin. Previously it had been rejecting my root/superuser PW. This time, after downloading the plugin to my machine and installing from Terminal it worked.
FYI - Although I had been able to print driverless previously, I needed HPLIP to enable scanning from my Ubunto 22.04 box. This HP DJ2700 is mainly useful to me not as a printer but as a cheap scanner. Many bumps along the road for me to get HPLIP to fully function.
Oh, and much thanks to Srikanth for posting the question & Manfred Hampl for the solution.