Is there current info on the Debian manual install?

Asked by Hawley Rising

The Debian HPLIP automatic installer fails miserably on Debian 11 for raspberry pi, demanding dependencies that are not available (e.g. python3-pyqt4) and for no reason. The "Manual Install" page only covers dependencies for Debian 5 and Debian 6. We're on 11, it was released in June, 5 & 6 were a long long time ago in a place far far away.

That's not all. Going on the canned HPLIP installation packaged with Debian 11 for R pi, the hp-setup hangs on my printer (OfficeJet 4630) with an "hpfax busy" forever, while intermediary to attempts, you can install it on Windows, de-install it on Windows, print, scan, and fax on Debian 11 amd-64, print test pages and all the rest, so the fax isn't busy.

So I'm looking for an up-to-date dependency list for Debian 11 for manual install (with packages that actually exist there), and a way to get inside of some of these tools or recompile or reinstall them so they aren't so buggy I can't get my printer installed at all.

Details: Running HPLIP automatic installer, even after hunting down dependencies and even after installing both Qt4 and Qt5 and even Qt Creator for good measure, will not install because it says
python3-pyqt4 REQUIRED
python3-pyqt5 REQUIRED
python3-pyqt4 OPTIONAL
python3-pyqt5 OPTIONAL
are needed for the gui. It does this on custom install even if all the options are answered "n" -- gui displays, scanning, fax, JetDirect, and others.
Details: Running hp-setup shows two printers for "Step 1" for USB printers, the OfficeJet 4630 and the LaserJet P1006 (which did install properly after several tries). If I select OfficeJet 4630, I get:
"Unable to communicate with the device. Please check the device and try again."
on the terminal screen, I get,

error: Device busy: hpfax:/usb/Officjet_4630_series?serial=CN47J3B0K105Y0
error: Unable to communicate with the device. Please check the device and try again.

I get the same error whether the device is dormant or fully on.

This did not happen on Debian 11 on an amd-64 machine, on that machine as well the HPLIP automatic installer ran without my having to manually supply anything at all (it did load dependencies from somewhere).

I've looked at all the stack exchanges and seen others with the same problem, no solutions or solutions that don't work offered.

I can do the manual install, but I need information newer than Debian 6 which was released in 2006 before raspberry pi existed. And pyqt4 is deprecated, why does your installer need both 4 and 5?

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

Have you tried installing the modified package in the Debian repository
sudo apt install hplip hplip-gui

Revision history for this message
Hawley Rising (hkr3) said :

Thanks for answering.

I just tried this, because I hadn't tried the hplip-gui package before. It was no change. hplip-setup still can't see the printer with the same error about hpfax, the driver still reports back printer busy, and that hasn't changed.

Revision history for this message
Manfred Hampl (m-hampl) said :

Are you sure that the "device busy" is caused by the driver and not by the printer itself?

Revision history for this message
Hawley Rising (hkr3) said :

The "device busy" is the text error message from hp-setup. I'm sure that I can take the cable from the printer off the raspberry pi and plug it into a debian amd64 machine and have it work properly from there with no change in state, and that I can access the printer by wireless from Windows and do the same. Neither of the printers worked straight from a CUPS install, the other one, the Laserjet, worked after running hp-setup on it, and then tinkering in CUPS. This one I can't get through hp-setup because of this error. The problem seems to be with hp-setup, not with the device.

hp-setup checks the device, and tries to install two machines a printer and a fax printer. I think it is having problems with the fax printer. I tried unplugging the phone line, it had no effect. I tried shutting down anything fax on the printer (it doesn't have a setting to do so, but I turned off answering, etc.) and no effect.

On the debian amd64 machine, hp-setup runs fine with this printer and does not think the device is off or busy.

Revision history for this message
Hawley Rising (hkr3) said :

I got the printer sort-of running (meaning I got the 801.11 wireless to set up on the raspberry pi, but not the USB). I saw this:

on the stack exchange, and jury rigged it as a solution as follows:

I had already messed with the files so I cleaned up by rm -rf hplip-3.22.6 to get rid of the install directory under Downloads. Then I copied the "configure" statement from the referenced link. There are neither the lib64 he corrects, nor his x86_64_lib, and the only directory that makes sense is /usr/lib, so I substituted that.

The make runs with the same error about no, but after doing so, there was enough installed that I could do a
make install
and get something.
It turned out I had enough to have the HP Device Manager installed in toto on the raspberry pi, just that the same hp-setup problem still happened, but I was able by using HP Device Manager to install the Officejet 4630 wireless, and all of it works. The graphical also works on the Xfce interface (what I have loaded on the pi), as does scan, fax, printer status and the rest.

I would still love to see a fix for the problem, but I do have my printer working off the raspberry pi at this point. It pretty much narrows down what's wrong to hp-setup in the USB printers part.

I'm going to check "I'm Providing More Information" to see if anyone has an idea from what I did, but if not, I will later on check problem solved. Thanks for your help Manfred.

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.