Failed scanning with HP 8020 ethernet

Asked by PALMER

Hi ,
I have successfully installed the my new HP Officejet Pro 8020 AIO.
Linux Mint 20.2 (and tested with 20.3 Beta too)
HPlip 3.21.12 ( the last as of today), installed in cli only . The HPlip-gui fails to install due to qt5 issues

It prints perfectly but it does not scan via ethernet.
The error I receive is :
"Failed to start scanner : Error during device I/O"

Strange thing, it scans perfectly if I connect it via USB cable to my laptop.

If I try "hp-check -t "

I get the following error :

/usr/bin/hp-check:685: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  if 'getfacl' not in g and '' is not g and 'file' not in g:
warning: CUPSEXT could not be loaded. Please check HPLIP installation.

Any help ?


Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best brian_p (claremont102) said :

I do not know what is happening with scanning and HPLIP.
However, I do know that your device is supported by sane-airscan.


  sudo apt install sane-airscan

Revision history for this message
PALMER (forum-techfin) said :
Revision history for this message
PALMER (forum-techfin) said :

Thanks brian_p, that solved my question.

Revision history for this message
brian_p (claremont102) said :

Splendid! Thanks for the feedback.