Can't install HP1102w printer after update to MintLinux 20.1

Asked by Pauline Armitage

Following update from MintLinux 18.1 to 20.1 I run the "sudo hp-plugin" in terminal. I get a response Error: /root/.hplip-3.20.11 file does not match its checksum File may have been corrupted or altered.

I only seem to be able to download a later version of hplip 3.21.10 (I have tried to Manually install install this using a command from an earlier question sh ./hplip-3.21.10 but only get "sh: 0: Can't open ./hplip-3.21.10)

Being a plain user not a 'techie', I don't know what to do next other than buy a new printer. Can anyone help with simple instructions, please?

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Jonathan (jams01) said :

So do you already downloaded the plugin? and execute it?

Revision history for this message
Pauline Armitage (auntieparm) said :

Thank you Jonathan, your help is appreciated. Your link does go to the page where the plugin's are listed but I can't see how one downloads the plug-in. Attempts to click on it only shows a listing of the program with no clear way to download it (copy & paste doesn't seem to work). Clicking the "Download" only seems to give the download for the main HPLIP program, not the plug-in. I did run the HPLIP installation (so now using 3.20.10) so as to update in the hope that would cure the problem. When I try to run the routine to install the plug-in from a gui dialogue box or from the sudo hp-plugin command in terminal, it seems to fail. If I seem 'thick' I can only apologise. I'm doing my best. HP don't seem to be interested in helping.

Revision history for this message
Best Manfred Hampl (m-hampl) said :

There is no 3.20.10 version of HPLIP, I assume that are you using 3.21.10 (or is it 3.20.11, in that case you have to replace 3.21.10 by 3.20.11 in the rest of this text)

Visit with your web browser
scroll down to the end and click on the blue text with your RIGHT mouse button. You should get a small pop-up where you can select "Save link as" or "Save target as" (exact text depending on your browser).
When you get a window to select the target for saving, you best select the Downloads folder.

When that is done, open terminal window (e.g. by simultaneously pressing ctrl-alt-t)
Type into that window the following commands

cd Downloads
sh ./

If there is any problem, don't hesitate to ask again.

Revision history for this message
Pauline Armitage (auntieparm) said :

Thanks Manfred Hampl, that solved my question.