Install is not working

Asked by Lucinda Shephard

I downloaded hplip and when I click on it - it does start to extract the files but I, then when it's almost through, get an error message saying that the file has some invalid characters, if I continue to edit the file, I could corrupt the document. It says I can choose another character Encoding.

When I try to select another character encoding or retry to edit anyway or cancel - it freezes. What should I do?

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :

follow the installation instructions.

You should not do a double click on the file, but open a terminal window and start the installation with "sh hplip..."

Why do you use hplip 3.16.7? The newest version is 3.21.10

Revision history for this message
Lucinda Shephard (scotishmariner) said :

The hplip 3.16.7 was the only one I could download at the time. There was no other option from the web page . But my problem was solved as far as the installation went. But when I tried to discover my printer in the hp setup - it wouldn't see it. I have a HP Deskjet 2600 all in one and it's wireless. Kept coming up with an error about unblocking ports and the link the error box had was missing.