HPLIP install on RHEL 8.4 fails

Asked by edward earl eiland

when installing hplip 3.21-10 on RHEL, it fails due to conflicting requests:
# dnf install /home/earl/Downloads/hplip-3.21.10-RHEL8-x86_64.rpm
Updating Subscription Management repositories.
Last metadata expiration check: 0:14:08 ago on Sun 14 Nov 2021 07:15:16 PM CST.
Error:
 Problem: conflicting requests
  - nothing provides libImageProcessor.so()(64bit) needed by hplipfull-3.21.10-0.x86_64
  - nothing provides libImageProcessor.so(VERS_1.0)(64bit) needed by hplipfull-3.21.10-0.x86_64

Question information

Language:
English Edit question
Status:
Open
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
edward earl eiland (eearl51) said :
#1

I updated my RHEL install and re-tried installing hplip. The problem now has three errors:
# dnf install /home/earl/Downloads/hplip-3.21.10-RHEL8-x86_64.rpm
Updating Subscription Management repositories.
Last metadata expiration check: 0:45:38 ago on Mon 29 Nov 2021 10:46:57 AM CST.
Error:
 Problem: conflicting requests
  - nothing provides /usr/bin/python needed by hplipfull-3.21.10-0.x86_64
  - nothing provides libImageProcessor.so()(64bit) needed by hplipfull-3.21.10-0.x86_64
  - nothing provides libImageProcessor.so(VERS_1.0)(64bit) needed by hplipfull-3.21.10-0.x86_64

How do I resolve these dependencies?

Can you help with this problem?

Provide an answer of your own, or ask edward earl eiland for more information if necessary.

To post a message you must log in.