My HP printer stopped working. I dled the new driver but don't know how to install it. I'm new at this.

Asked by Suzanne E Hammond

My "Envy" HP printer stopped working in mid-print. I cannot get the driver I have to come up anymore. So I dled the current driver (hplip-3.21.6.run) but I don't know how to install it. All installations I have done in past were automated. I did not build this box, but my friend is disabled now.

Question information

Language:
English Edit question
Status:
Expired
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
brian_p (claremont102) said :
#1

Hello Suzanne,

Please give the precise printer model name, the distro you are using
and whether you want a USB or network connection.

Revision history for this message
Suzanne E Hammond (moreach) said :
#2

Printer makes good color copies, so the mechanism is ok, as are ink & paper.

Revision history for this message
Suzanne E Hammond (moreach) said :
#3

brian_p it's a HP Envy 5530 all-in-one copier/printer/etc. The hplip distro is 3.21.6 but may not be the one I really want. Because my friend and builder is now unable to help me, my Mnt is the older "Betsy" version. As I said before, the copy feature is working fine, in color, so I think (since it disappeared) it may be a driver problem. Before, I had HP's uiscan driver but it no longer runs.

Revision history for this message
Suzanne E Hammond (moreach) said :
#4

The printer is HP's "Envy" 5530. My Mint is the old "Betsy" distro because
I don't know how to update it *and it runs Ok).

On Fri, Aug 27, 2021 at 12:30 AM Suzanne E Hammond <
<email address hidden>> wrote:

> New question #698531 on HPLIP:
> https://answers.launchpad.net/hplip/+question/698531
>
> My "Envy" HP printer stopped working in mid-print. I cannot get the driver
> I have to come up anymore. So I dled the current driver (hplip-3.21.6.run)
> but I don't know how to install it. All installations I have done in past
> were automated. I did not build this box, but my friend is disabled now.
>
>
> --
> You received this question notification because you asked the question.
>

Revision history for this message
brian_p (claremont102) said :
#5

Please give the outputs of

dpkg -l hplip

lpinfo -v

lpinfo -m | grep 'drv.*5530'

Revision history for this message
Suzanne E Hammond (moreach) said :
#6

dpkg result = Desired=Unknown/Install/Remove/Purge/Hold
|
Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-=================================
ii hplip 3.14.6-1+deb amd64 HP Linux Printing and Imaging
Sys

lpinfo = suze@suzecomp:~$ Desired=Unknown/Install/Remove/Purge/Hold
suze@suzecomp:~$ |
Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
bash: syntax error near unexpected token `|'
suze@suzecomp:~$ |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
bash: syntax error near unexpected token `|'
suze@suzecomp:~$ ||/ Name Version Architecture Description
bash: syntax error near unexpected token `||'
suze@suzecomp:~$
+++-==============-============-============-=================================
+++-==============-============-============-=================================:
command not found
suze@suzecomp:~$ ii hplip 3.14.6-1+deb amd64 HP Linux
Printing and Imaging Sys
The program 'ii' is currently not installed. To run 'ii' please ask your
administrator to install the package 'ii'
ii: command not found
suze@suzecomp:~$

(This is a very old installation. "Betsy" is distro 2!)

Grep = drv:///hpijs.drv/hp-envy_5530_series-hpijs.ppd HP Envy 5530 Series
hpijs, 3.14.6
drv:///hpcups.drv/hp-envy_5530_series.ppd HP Envy 5530 Series, hpcups 3.14.6
drv:///hp/hpcups.drv/hp-envy_5530_series.ppd HP Envy 5530 Series, hpcups
3.19.1
drv:///splix-samsung.drv/scx5530fn.ppd Samsung SCX-5530FN, 2.0.0

Sadly I don't know what any of this means...

Suze aka Moreach

On Fri, Aug 27, 2021 at 4:20 PM brian_p <
<email address hidden>> wrote:

> Your question #698531 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/698531
>
> Status: Open => Needs information
>
> brian_p requested more information:
> Please give the outputs of
>
> dpkg -l hplip
>
> lpinfo -v
>
> lpinfo -m | grep 'drv.*5530'
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/hplip/+question/698531
>
> You received this question notification because you asked the question.
>

Revision history for this message
brian_p (claremont102) said :
#7

The 'dpkg -l hplip' tells us you have version 3.14.6 of hplip. You
do not require a new version because 3.14.6 supports your printer.

It is essential to have what is given by

  lpinfo -v

You did not provide that information.

There will be about 10 lines to the output. Make sure that what is
seen on the screen is what is copied and pasted in your next mail.

Revision history for this message
brian_p (claremont102) said :
#8

You are obviously reluctant to provide any further information. You should mark this thread as solved as far as you are concerned.

Revision history for this message
Suzanne E Hammond (moreach) said :
#9

I have supplied everything asked for, including the results of inxi -Fxz,
which evidently you missed. Yours, sadly, is the only answer so far.

Since you missed it, here:
suze@suzecomp:~$ inxi -Fxz
System: Host: suzecomp Kernel: 3.16.0-11-amd64 x86_64 (64 bit gcc:
4.9.2)
           Desktop: Cinnamon 3.4.6 (Gtk 3.14.5+4) Distro: LinuxMint 2 betsy
Machine: System: Dell product: OptiPlex 755
           Mobo: Dell model: 0GM819 Bios: Dell v: A09 date: 03/11/2008
CPU: Dual core Intel Core2 Duo E8200 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 10639
           Clock Speeds: 1: 2000 MHz 2: 2000 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] RV610 [Radeon HD 2400 PRO]
           bus-ID: 01:00.0
           Display Server: X.Org 1.16.4 drivers: ati,radeon (unloaded:
fbdev,vesa)
           Resolution: 1280x720@60.00hz
           GLX Renderer: Gallium 0.4 on AMD RV610
           GLX Version: 3.0 Mesa 10.3.2 Direct Rendering: Yes
Audio: Card Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k3.16.0-11-amd64
Network: Card: Intel 82566DM-2 Gigabit Network Connection
           driver: e1000e v: 2.3.2-k port: ecc0 bus-ID: 00:19.0
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 540.1GB (45.1% used)
           ID-1: /dev/sda model: ST340212AS size: 40.0GB
           ID-2: /dev/sdb model: WDC_WD5000AAKS size: 500.1GB
Partition: ID-1: / size: 9.1G used: 7.1G (83%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.00GB used: 1.40GB (17%) fs: swap dev:
/dev/sda2
Sensors: System Temperatures: cpu: 41.0C mobo: N/A gpu: 67.0
           Fan Speeds (in rpm): cpu: N/A

Need any more?

Suze/Moreach

On Tue, Aug 31, 2021 at 11:50 AM brian_p <
<email address hidden>> wrote:

> Your question #698531 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/698531
>
> brian_p posted a new comment:
> You are obviously reluctant to provide any further information. You
> should mark this thread as solved as far as you are concerned.
>
> --
> You received this question notification because you asked the question.
>

Revision history for this message
Suzanne E Hammond (moreach) said :
#10

No outputs, this is a Very Old Distro, #2 in fact.

On Fri, Aug 27, 2021 at 4:20 PM brian_p <
<email address hidden>> wrote:

> Your question #698531 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/698531
>
> Status: Open => Needs information
>
> brian_p requested more information:
> Please give the outputs of
>
> dpkg -l hplip
>
> lpinfo -v
>
> lpinfo -m | grep 'drv.*5530'
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/hplip/+question/698531
>
> You received this question notification because you asked the question.
>

Revision history for this message
Suzanne E Hammond (moreach) said :
#11

Sorry, spoke too soon... grep said:
drv:///hpijs.drv/hp-envy_5530_series-hpijs.ppd HP Envy 5530 Series hpijs,
3.14.6
drv:///hpcups.drv/hp-envy_5530_series.ppd HP Envy 5530 Series, hpcups 3.14.6
drv:///hp/hpcups.drv/hp-envy_5530_series.ppd HP Envy 5530 Series, hpcups
3.19.1
drv:///splix-samsung.drv/scx5530fn.ppd Samsung SCX-5530FN, 2.0.0

On Fri, Aug 27, 2021 at 4:20 PM brian_p <
<email address hidden>> wrote:

> Your question #698531 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/698531
>
> Status: Open => Needs information
>
> brian_p requested more information:
> Please give the outputs of
>
> dpkg -l hplip
>
> lpinfo -v
>
> lpinfo -m | grep 'drv.*5530'
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/hplip/+question/698531
>
> You received this question notification because you asked the question.
>

Revision history for this message
Suzanne E Hammond (moreach) said :
#12

dpkg -l hplip
Desired=Unknown/Install/Remove/Purge/Hold
|
Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-=================================
ii hplip 3.14.6-1+deb amd64 HP Linux Printing and Imaging
Sys

On Fri, Aug 27, 2021 at 4:20 PM brian_p <
<email address hidden>> wrote:

> Your question #698531 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/698531
>
> Status: Open => Needs information
>
> brian_p requested more information:
> Please give the outputs of
>
> dpkg -l hplip
>
> lpinfo -v
>
> lpinfo -m | grep 'drv.*5530'
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/hplip/+question/698531
>
> You received this question notification because you asked the question.
>

Revision history for this message
Suzanne E Hammond (moreach) said :
#13

Sorry I was so hasty, also got this:

lpinfo -v
network http
network https
network ipps
network ipp
network ipp14
network socket
network lpd
serial serial:/dev/ttyS0?baud=115200
direct parallel:/dev/lp0
direct usb://HP/ENVY%205530%20series?serial=CN4CG363GV05XT&interface=1
direct hp:/usb/ENVY_5530_series?serial=CN4CG363GV05XT
network smb

On Fri, Aug 27, 2021 at 4:20 PM brian_p <
<email address hidden>> wrote:

> Your question #698531 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/698531
>
> Status: Open => Needs information
>
> brian_p requested more information:
> Please give the outputs of
>
> dpkg -l hplip
>
> lpinfo -v
>
> lpinfo -m | grep 'drv.*5530'
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/hplip/+question/698531
>
> You received this question notification because you asked the question.
>

Revision history for this message
Suzanne E Hammond (moreach) said :
#14

I am also having other, email, probs.... apologize again! :-(

On Fri, Aug 27, 2021 at 4:20 PM brian_p <
<email address hidden>> wrote:

> Your question #698531 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/698531
>
> Status: Open => Needs information
>
> brian_p requested more information:
> Please give the outputs of
>
> dpkg -l hplip
>
> lpinfo -v
>
> lpinfo -m | grep 'drv.*5530'
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/hplip/+question/698531
>
> You received this question notification because you asked the question.
>

Revision history for this message
Launchpad Janitor (janitor) said :
#15

This question was expired because it remained in the 'Open' state without activity for the last 15 days.