qt4 is not avalible in debian bullseye

Asked by Steve T.

I am trying to install hplip 3.21.6 but it requires python3-pyqt4 which my distribution doesn't have (and so might be others in the future since qt4 is deprecated).

Funnily, python3-pyqt5 is only optional (qt5 is current) so please update to qt5.

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Steve T.
Last query:
Last reply:
Revision history for this message
Steve T. (somerandomuser240907) said :

Ha I just looked through the python scripts and figured out the way
command: bash hplip-X.XX.XX.run -- --no-qt4

Revision history for this message
paisleynatalie (nataly446644) said (last edit ):

Hi all,

I am using Bullseye (testing) because some of the software I use need
some of the newer libraries. Unfortunately Bullseye no longer includes
the Qt4 libraries and some of my packages still need Qt4. How can I
Qt4 packages for Bullseye. There is probably a backport for this but I
have not used backport in the past. I will need a step by step procedure
if backporting is needed.Bug listing

Any help will be sincerely appreciated.
Regard: apknames.com

Revision history for this message
Steve T. (somerandomuser240907) said (last edit ):
Revision history for this message
Steve T. (somerandomuser240907) said :

i once tried adding the buster repo into my apt configuration which has qt4 libs but that didn't work
so update your software because they probably are very old and also qt4 is deprecated