how to install HP smart tank 500

Asked by David Hotrum on 2021-05-11

I downloaded the hplip-3.21.4 and uncompressed in its own sub. Running hplip-install on the terminal only goes as far as needing many dependances. I click yes and the program halts and clears from the screen. I read on another site that there is NO work around for this? All dependancies are not available? What do I do now?

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
David Hotrum
Solved:
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :
#1

Which operating system (including version number) are you running?

Remark: The recommended way to install HPLIP is the command
sh hplip-3.21.4.run

Revision history for this message
David Hotrum (dhotrum52) said :
#2

The response is : sh: 0: Can't open hplip-3.21.4.run
I am running Linuxmint 20.1 Cinnamon as per system settings

Revision history for this message
David Hotrum (dhotrum52) said :
#3

ystem: Kernel: 5.4.0-73-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.8.6
           wm: muffin dm: LightDM Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal
Machine: Type: Desktop Mobo: ASUSTeK model: EX-H310M-V3 R2.0 v: Rev X.0x serial: <filter>
           UEFI: American Megatrends v: 1004 date: 10/11/2019
CPU: Topology: Dual Core model: Intel Pentium Gold G5400 bits: 64 type: MT MCP
           arch: Kaby Lake rev: A L2 cache: 4096 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 29598
           Speed: 800 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800
Graphics: Device-1: Intel vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0
           chip ID: 8086:3e90
           Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics 610 (CFL GT1) v: 4.6 Mesa 20.2.6
           direct render: Yes
Audio: Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus ID: 00:1f.3 chip ID: 8086:a2f0
           Sound Server: ALSA v: k5.4.0-73-generic
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK
           driver: r8169 v: kernel port: e000 bus ID: 02:00.0 chip ID: 10ec:8168
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: Local Storage: total: 987.42 GiB used: 92.47 GiB (9.4%)
           ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB speed: 6.0 Gb/s
           serial: <filter>
           ID-2: /dev/sdb vendor: Generic model: S050 Hard drive size: 465.76 GiB speed: 6.0 Gb/s
           serial: <filter>
           ID-3: /dev/sdc vendor: Seagate model: ST380815AS size: 74.53 GiB speed: 3.0 Gb/s
           serial: <filter>
Partition: ID-1: / size: 438.12 GiB used: 38.35 GiB (8.8%) fs: ext4 dev: /dev/sda4
Sensors: System Temperatures: cpu: 29.8 C mobo: 27.8 C
           Fan Speeds (RPM): N/A
Repos: No active apt repos in: /etc/apt/sources.list
           Active apt repos in: /etc/apt/sources.list.d/brave-browser-release.list
           1: deb [arch=amd64] https: //brave-browser-apt-release.s3.brave.com/ stable main
           No active apt repos in: /etc/apt/sources.list.d/obsproject-obs-studio-focal.list
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
           1: deb http: //packages.linuxmint.com ulyssa main upstream import backport
           2: deb http: //my.mirrors.thegigabit.com/ubuntu focal main restricted universe multiverse
           3: deb http: //my.mirrors.thegigabit.com/ubuntu focal-updates main restricted universe multiverse
           4: deb http: //my.mirrors.thegigabit.com/ubuntu focal-backports main restricted universe multiverse
           5: deb http: //security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http: //archive.canonical.com/ubuntu/ focal partner
Info: Processes: 203 Uptime: 5m Memory: 7.64 GiB used: 1023.4 MiB (13.1%) Init: systemd
           v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Client: Unknown python3.8 client
           inxi: 3.0.38

Revision history for this message
Manfred Hampl (m-hampl) said :
#4

"sh: 0: Can't open hplip-3.21.4.run"

You have to "cd" into the directory where the *.run file is, first.

Revision history for this message
David Hotrum (dhotrum52) said :
#5

I did. I cd into Downloades/hplip-3.21.4 where the whole down load is
Where can I send a pic of a screenshot?

Revision history for this message
David Hotrum (dhotrum52) said :
#6

This is install log

hplip-install[2005]: info: :
hplip-install[2005]: info: :[01mHP Linux Imaging and Printing System (ver. 3.21.4)[0m
hplip-install[2005]: info: :[01mHPLIP Installer ver. 5.1[0m
hplip-install[2005]: info: :
hplip-install[2005]: info: :Copyright (c) 2001-18 HP Development Company, LP
hplip-install[2005]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hplip-install[2005]: info: :This is free software, and you are welcome to distribute it
hplip-install[2005]: info: :under certain conditions. See COPYING file for more details.
hplip-install[2005]: info: :
hplip-install[2005]: info: :Installer log saved in: [01mhplip-install_Tue-11-May-2021_16:19:51.log[0m
hplip-install[2005]: info: :
hplip-install[2005]: info: :
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
hplip-install[2005]: info: :
hplip-install[2005]: info: :
hplip-install[2005]: info: :[01mINSTALLATION MODE[0m
hplip-install[2005]: info: :[01m-----------------[0m
hplip-install[2005]: info: :Automatic mode will install the full HPLIP solution with the most common options.
hplip-install[2005]: info: :Custom mode allows you to choose installation options to fit specific requirements.
hplip-install[2005]: info: :
hplip-install[2005]: info: :
hplip-install[2005]: info: :[01mINTRODUCTION[0m
hplip-install[2005]: info: :[01m------------[0m
hplip-install[2005]: info: :This installer will install HPLIP version 3.21.4 on your computer.
hplip-install[2005]: info: :Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).
hplip-install[2005]: info: :
hplip-install[2005]: info: :
hplip-install[2005]: info: :[01mDISTRO/OS CONFIRMATION[0m
hplip-install[2005]: info: :[01m----------------------[0m
hplip-install[2005]: info: :Distro appears to be Linux Mint 20.1.

hplip-install[2005]: info: :
Initializing. Please wait...
hplip-install[2005]: info: :
hplip-install[2005]: info: :
hplip-install[2005]: info: :[01mENTER USER PASSWORD[0m
hplip-install[2005]: info: :[01m-------------------[0m
hplip-install[2005]: info: :
hplip-install[2005]: info: :
hplip-install[2005]: info: :[01mINSTALLATION NOTES[0m
hplip-install[2005]: info: :[01m------------------[0m
hplip-install[2005]: info: :Enable the universe/multiverse repositories. Also be sure you are using the Ubuntu "Main" Repositories. See: https://help.ubuntu.com/community/Repositories/Ubuntu for more information. Disable the CD-ROM/DVD source if you do not have the Ubuntu installation media inserted in the drive.
hplip-install[2005]: info: :
hplip-install[2005]: info: :
hplip-install[2005]: info: :
hplip-install[2005]: info: :[01mSECURITY PACKAGES[0m
hplip-install[2005]: info: :[01m-----------------[0m
hplip-install[2005]: info: :AppArmor is installed.
hplip-install[2005]: info: :AppArmor protects the application from external intrusion attempts making the application secure
hplip-install[2005]: info: :
hplip-install[2005]: info: :
hplip-install[2005]: info: :[01mRUNNING PRE-INSTALL COMMANDS[0m
hplip-install[2005]: info: :[01m----------------------------[0m
hplip-install[2005]: info: :OK
hplip-install[2005]: info: :
hplip-install[2005]: info: :
hplip-install[2005]: info: :[01mRUNNING HPLIP LIBS REMOVE COMMANDS[0m
hplip-install[2005]: info: :[01m----------------------------------[0m
hplip-install[2005]: info: :sudo apt-get remove libhpmud0 libsane-hpaio printer-driver-postscript-hp ( hp_libs_remove step 1)
hplip-install[2005]: info: :OK
hplip-install[2005]: info: :
hplip-install[2005]: info: :
hplip-install[2005]: info: :[01mMISSING DEPENDENCIES[0m
hplip-install[2005]: info: :[01m--------------------[0m
hplip-install[2005]: info: :Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
hplip-install[2005]: info: :Package-Name Component Required/Optional
hplip-install[2005]: info: :pyqt5-dbus gui_qt5 OPTIONAL
hplip-install[2005]: info: :libcrypto network REQUIRED
hplip-install[2005]: info: :libnetsnmp-devel network REQUIRED
hplip-install[2005]: info: :sane-devel scan REQUIRED
hplip-install[2005]: info: :pil scan OPTIONAL
hplip-install[2005]: info: :python-devel base REQUIRED
hplip-install[2005]: info: :cups-devel base REQUIRED
hplip-install[2005]: info: :libavahi-dev scan REQUIRED
hplip-install[2005]: info: :reportlab fax OPTIONAL
hplip-install[2005]: info: :pyqt5 gui_qt5 REQUIRED
hplip-install[2005]: info: :libusb base REQUIRED
hplip-install[2005]: info: :libtool base REQUIRED
hplip-install[2005]: info: :cups-image base REQUIRED
hplip-install[2005]: info: :python-notify gui_qt5 OPTIONAL
hplip-install[2005]: info: :xsane scan OPTIONAL
hplip-install[2005]: info: :libjpeg base REQUIRED
hplip-install[2005]: info: :dbus fax REQUIRED
hplip-install[2005]: info: :
hplip-install[2005]: info: :
hplip-install[2005]: info: :[01mINSTALL MISSING REQUIRED DEPENDENCIES[0m
hplip-install[2005]: info: :[01m-------------------------------------[0m
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: python-devel (Python devel - Python development files)
warning: This installer cannot install 'python-devel' for your distro/OS and/or version.
error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.

Revision history for this message
David Hotrum (dhotrum52) said :
#7

It is my time to retire for the night. If you have a new suggestion than please let me know and i will try again tomorrow.

Revision history for this message
David Hotrum (dhotrum52) said :
#8

I made sure python-devel was installed. It and many files were installed. Still no change. Install program still needs all those files before going any further.

Revision history for this message
Manfred Hampl (m-hampl) said :
#9

Which "python-devel" program did you install?

I assume in Linuxmint 20.1 it should be python3-dev

Revision history for this message
David Hotrum (dhotrum52) said :
#10

Yes, Python3-dev was installed. That got rid of the last line of the log file. I will try something today I will put each file name into a search and see what comes up.
BTW thank you for all your time and scratching your head along with mine.

Revision history for this message
David Hotrum (dhotrum52) said :
#11

I have slowly been finding the files. They are not in one place. I have worked my way down the list to libavahi-dev Here is the list again:

Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name Component Required/Optional
pyqt5-dbus gui_qt5 OPTIONAL
libnetsnmp-devel network REQUIRED
sane-devel scan REQUIRED
pil scan OPTIONAL
cups-devel base REQUIRED
libavahi-dev scan REQUIRED
reportlab fax OPTIONAL
pyqt5 gui_qt5 REQUIRED
libusb base REQUIRED
libtool base REQUIRED
cups-image base REQUIRED
python-notify gui_qt5 OPTIONAL
xsane scan OPTIONAL
libjpeg base REQUIRED
dbus fax REQUIRED
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ?

Even when some of the files are installed it still gives the same list. Maybe you have a good source for these files?

Revision history for this message
David Hotrum (dhotrum52) said :
#12

I live in a 3rd world country and my internet is so slow it stopped downloading. I will have to try again tomorrow AM. I have found this. Python3-dev must be installed then pip3 installed then update&&upgrade. cups-devel can be installed with install -f hplip. reportlab got installed somewhere along the way. Everything that is Python must be installed through pip3. All this is a real pain but now I must wait until tomorrow AM and try again.

Revision history for this message
David Hotrum (dhotrum52) said :
#13

I have decided it was a total waste of money and time. HP does not care about their Linux customers. I have downloaded hundreds of files and packages. Hp gives the wrong name for needed files, I searched the internet trying to find the package required and found Linux gave it a different name. I cannot return this printer because I live in the Philippines and things you buy , generally speaking , are not returnable. I could have bout a Brother for $25 more. I have thrown away $250 and 2 days fighting. I give up

Revision history for this message
David Hotrum (dhotrum52) said :
#14

My advice to anyone looking at a HP super tank 500. They aren't ready for linux yet. I took my HP back to the store and they exchanged it for a cheaper one. An Epson L3110

Revision history for this message
David Hotrum (dhotrum52) said :
#15

I gave up and returned the printer for a different brand