Can't install HPLIP 3.21.2 on Linux Mint 20.1 ...

Asked by Elvio Lampugnani on 2021-05-03

Hi!

I have been installed Linux Mint 20.1 installed on my PC.

When I try to install HPLIP 3.21.2 (to replace actual hplip-3.20.11), a red message says that 3.21.2 is not compatible with mint 20.1.

In the topic "Linux distributions supported by the automatic installer", says:

...

Linux Mint (17, 17.1, 17.2, 17.3, 18, 18.1, 18.2, 18.3, 19, 19.1,19.2,19.3,20.04)

...

but, the version sequence is: Mint 19.3, 20 and 20.1, not 20.04. Apparently, "20.04" refers to Ubuntu.
Perhaps making the correct identification of the Mint version, at this moment 20.1, can solve this issue.

Thank you.

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Jason D. Stone (jasonstone20) said : #1

try sudo apt install hplip hplip-gui
then
hp-setup
you might have to install python3-pyqt5:
sudo apt install pythone3-pyqt5

Can you help with this problem?

Provide an answer of your own, or ask Elvio Lampugnani for more information if necessary.

To post a message you must log in.